Xbox Series X connect with Beam Gen 2 Dolby Atoms bypass issue

  • 26 November 2022
  • 5 replies

I just got my Beam Gen2, and I connect it to my TV with HDMI (eARC) Port.

My Xbox series X is connecting to another HDMI port on my TV.

But I found that my Xbox not recognize any dolby atoms device, 

I did some research online, the above connection method should be able to do the bypass.

See if anyone have this experience about it.




Best answer by GuitarSuperstar 26 November 2022, 07:36

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7

What model TV do you have? What specific Dolby Atmos content are you testing? From what app?

I’m using Samsung 70" 4K UHD HDR LED Tizen OS Smart TV 
and I was playing disney+ on my Xbox to test the Dolby atmos, the movies details shows no Dolby atmos icon.

But when I play the same movie on my TV, it can play by Dolby.

I am testing it because I want to play some bluray on my Xbox later, so, wanna see how to fix it.


Thanks a lot.

Userlevel 7

What specific movie are you testing on Disney+?

Be sure to set the Digital Output Audio Format setting on the TV to Passthrough and enable eARC.

On the Xbox, set the HDMI Audio setting to Dolby Atmos for home theater and enable Allow Passthrough.

After you have adjusted these settings, test the film Black Panther on Disney+ and tell me what audio format is displayed on the Now Playing screen in the Sonos app.

I was testing the end game. 
let me try your suggestion and do it again, thanks for advice.


Hi! I tried the setting you taught me and it works! thank you so much! Have tested Black Panther, it can play by Dolby Atmos now! :)