Question

System Update Failing

  • 10 May 2024
  • 2 replies
  • 52 views

I recently purchased a Sonos Playbar and 2 x Play 3 speakers second hand.  I have spent ALL DAY trying to set the speakers up in the Sonos App.  I did a reset on all three speakers as advised.  Multiple attempts have been made, rebooting both the modem and the speakers, uninstalling the app and reinstalling.  I have tried EVERY SINGLE FIX I could find on line but still no luck.  I'm using my Android phone with the app and have tried both wired and wireless setup.  When trying to add a device, I keep getting to the point where the app wants me to run an update in order to finish the set up, I go through that process, the update begins and very slowly moves through the process but stops each time about ¾ way through every time!  By then, the speaker times out because it's been more than 30 mins.  I have good, uninterrupted wifi so that can't be the problem.  HELP!!


2 replies

Userlevel 7
Badge +19

Very frustrating for any owner! 

The speakers you now own are quite old. The previous owner may have kept them on the older S1 version of the app. If so, it may be too much of a jump to get from the version the speakers are currently running straight to the current version. 
 

Speak to Sonos support - they probably can help get you to the latest version - if that is the problem, of course. But they may also be able to trouble-shoot your issue. 
 

Thanks for that. Yeah, they are older but all the literature I'd read before buying ensured that they would still be capable of updates. I held on the Sonos helpline and gave up after 30 minutes 🙄

Reply