Answered

Surrounds not working

  • 27 May 2023
  • 6 replies
  • 104 views

We've recently changed our broadband to BT. The beam is working fine but no sounds from SL1 surrounds..they all say connected..I've tried factory resetting and rebooting the router. In the system info it says surrounds won't work with the WiFi? But when I take them off as surrounds and added just as speakers they work fine with the WiFi. Can anyone shed any light ? 

 

Moderator edit: redacted serial numbers from picture

icon

Best answer by Corry P 1 June 2023, 13:31

View original

6 replies

Userlevel 7
Badge +18

Have you disabled the wifi on your Beam? It needs to be enabled to create the dedicated 5Ghz wifi link to the surrounds. 

That warning is curious because the (RS) and WM:3 for the surround shown in your image indicates that it is setup as a wireless surround speaker. 

Userlevel 7
Badge +18

Hi @MrsLCD97 

Welcome to the Sonos Community!

It is not your BT router that is causing problems, but your WiFi Extender - WiFi Extenders are not supported by Sonos for exactly this reason (and others). To remedy, I recommend you connect your Sonos system to your router’s WiFi rather than to the Extender’s.

First, make sure that your phone is connected to BT-KQCT76 and not to BT-KQCT76_EXT. Please then open the Sonos app and select Settings » System » Network » Manage Networks » Update Networks and connect Sonos to BT-KQCT76. Once connected, and again in the Manage Networks page, tap on the icon next to BT-KQCT76_EXT to remove it from your Sonos system and prevent Sonos from connecting to it.

I hope this helps.

We've been using it on an extender since we bought in 2020 without issue. It only stopped working once we changed to BT. If we could connect to the main router we would - we have the extender as main router signal is weak in this room. 

Which is why Sonos says they don’t support extenders. Some appear to work without issue, others, not so much. 

From the various threads about BT routers and extenders that I’ve read in these forums over the years, I’d be using their equipment as only a modem, and setting up my own router network. 

Userlevel 7
Badge +18

Hi @MrsLCD97 

We've been using it on an extender since we bought in 2020 without issue. It only stopped working once we changed to BT. If we could connect to the main router we would - we have the extender as main router signal is weak in this room. 

I would presume that the extender and the BT router are not playing well together, and your Sonos system is left with the consequences.

If your extender has not been rebooted since you replaced the router, I highly recommend you turn it off and on again.

I suspect, however, that you may need to get a BT WholeHome extender which should work better with your new router. Which is not to say that @Airgetlam doesn’t make an excellent recommendation - no router supplied for free is going to be the best available.

I hope this helps.

Reply