Answered

Soundbar and two Ones do not join the same room


I have one Sonos Soundbar and two Sonos Ones (G2) that simply do not want to be part of the same room. Two Ones were set up as Living Room and play nicely. When I try to add Soundbar it is always created as a separate “Living Room 2”. I can group them as two separate rooms to play the same music, but if I try to tune them they get tuned independently as two separate rooms.

Any way to make all three speakers part of the same room as the same setup? 

icon

Best answer by 106rallye 8 July 2023, 16:45

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

You need to ‘add surrounds’ to the ‘room’ that is the Sonos sound bar (of whichever type that is), which will put them in the same ‘room’. 

And before you add the Ones, separate the stereo pair.

The reason t=you have to start from the soundbar is that the soundbar controls the HT setup.  These speakers are NOT grouped.  You must use “add surrounds” in the soundbar settings.  The Ones then ‘bond’ to the soundbar and just play what the soundbar sends them. 

Userlevel 7
Badge +17

As explained here: https://support.sonos.com/en-us/article/add-surround-speakers-to-a-sonos-home-theater

Thank you! 
I followed the instructions and with some hurdles was able to make all 3 speakers (Soundbad and 2 Sonos One Gen 2 speakers) part of the same surround group. Breaking the stereo pair of 2 Sonos Ones was not enough, I had to do full reset on them in order to re-add them to the room with my Soundbar. Until a reset, Sonos app was showing only one of two speakers available for adding to the surround setup and any attempt to add one speaker was failing.
After full reset of the two Sonos Ones, all three are acting as one room now.
Whoo-hoo! and thank you.