Answered

Sonos sub refusing to join any group in my house

  • 11 July 2023
  • 9 replies
  • 1229 views

I had a Sonos sub that worked fine connected to an Arc + two surrounds group. I deleted it and tried to pair it to another group with an Arc and two surrounds in my house. It wouldn’t accept joining the group. I performed a factory reset. re Added the sub to my Sonos house system. Then tried to add it to either an Arc group or a Beam group and in both cases it refuses to join them. It reports having a strong wifi signal and nothing else has changed in my house. Totally at a loss for why. I have 20 speakers and two other subs and know the process very well. It seems that sub is stuck and while is accepting getting on the network it doesn’t accept anymore being added to anything. 

icon

Best answer by GuitarSuperstar 11 July 2023, 04:44

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Userlevel 7

Did you properly remove the Sub from the first Arc using the “Remove Sub” option in the Sonos app?

Are you using the “Connect Sub” option to add the Sub to the other Arc or Beam?

When you say “it refuses to join them” what message are you getting in the Sonos app?

Yea I did remove it first without issues. Then tried to add it to another group without success. Then tried to add it back to its initial group without success. Then performed the factory reset. The initial process of finding the sub and adding it to the list of devices works fine. Wifi signal is solid. I see the sub as an unassigned device in my

list.  But when I try to add it to any other product I get the error screen “there was a problem adding your sub. Check the network connection and make sure your product power is on”. Obviously power is on and wifi is strong (SNR 75 DB) which is why I can see it in my decode list. I loved two other subs without any issues by the way. It is just this one giving me trouble. 

Userlevel 7

Try unplugging the Arc and Sub from power for a couple of minutes and reboot your router and phone.

Userlevel 7
Badge +17

For future reference: the correct Sonos lingo for a stand alone speaker, a stereo pair or a surround set is a “room”. “Rooms” can be “grouped”. So where you say “group” you actually mean a “room”.

Have you physically moved the SUB so that IT is within 5GHz wireless range of the ARC?

Thanks for the correction in lingo. Agree that I should have stated joining a room and not a group. Anyhow rebooted the router and that was the issue. I think IP adresses were stuck and that was keeping the sub from going thru the joining process. however that created another big set of problems for me with Sonos rooms all mixed up and even old names of rooms coming back. Seems like the software has some sort of phantom memory. Room names I changed months ago are back ??? As a result speakers are grouped in a weird way sometimes. Also I get a different list every time I launch the app with problems randomly showing in different rooms. Total mess. Definitely software bugs in there. 

I doubt very much there are software bugs.  Have you rebooted ALL the devices on your network, Sonos and other?  If you have had IP address issues this is essential.

Also, a few routers struggle to get IP addressing right for Sonos devices that connect via another device, e.g. a Sub connecting via an Arc.  If this is the case with your router, it would be better to remove the Subs and surrounds from their soundbars, reboot everything, then re-add Subs and surrounds.

After another router reboot I decided to ignore all the error messages and simply tap on the wrench icon in every room portraying an error. The error goes away without any other action and I now have my entire system back together as it should and that reluctant sub added to

the proper room. Basically the software reports “shadow” errors. They seem to stem from the system not properly recording movements. For example two subs that I moved from one Arc to another showed back in the previous room but when I clicked on the wrench error it simply disappeared. They are linked to the proper room and work fine. 
 

so I think the take away is to make sure you reboot your router anytime you move devices from one room to another and ignore any error messages about room attribution when you relaunch the app. Clearly a software bug Sonos needs to address