Answered

Sonos Sub 3 stopped working on WiFi

  • 19 August 2022
  • 16 replies
  • 171 views

Userlevel 3
Badge +5

Hi. 

For some reason my Sonos Sub 3 has stopped working on WiFi but I have since solved the problem by connecting my Sub directly to my router.

However I am curious as to why this should happen on WiFi but not on an ethernet connection?

I now have my Arc and Sub connected directly to my router with just my 2 One SL's connecting via WiFi as I have had no issues with my 2 surround speakers!

It was only with the Arc and Sub that I had connection issues.

It was strange as when I had the problem the Sub was showing on the Sonos app but no sound was coming out of the Sub whilst it was on WiFi.

Just curious. 

By the way I have tried all the usual things like rebooting my router etc.

Just to add that before when I only had the Arc on a wired connection (I think it's called SonosNet), on the Sonos app under 'About My System' I only used to have the Arc on WM:0 but now not only is the Sub on WM:0 but the 2 SL's are as well and they are still on WiFi?

How is that?

I would have thought that my 2 SL's would still be showing as WM:1 meaning connected via a wireless connection?

Thanks for any feedback 👍 

 

Moderator Note: Modified so it’s all in one post, otherwise it looks like it has been replied to already.

icon

Best answer by MikeE67 19 August 2022, 15:37

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

16 replies

Can i just check one thing? On the wired Arc it still has WiFi enabled? You haven't ticked 'Disable WiFi' in the Arc settings?

Userlevel 3
Badge +5

@John B - I have ticked 'Disable WiFi' but only on the Arc.

 

I thought it only applied to the Arc, that's why I did it.

 

EDIT: I have also disabled WiFi on my Sub and now my 2 SL's are showing as WM:1

I don't really understand what's going on but it's all sorted now!

 

@John B - I have ticked 'Disable WiFi' but only on the Arc.

 

I thought it only applied to the Arc, that's why I did it.

 

EDIT: I have also disabled WiFi on my Sub and now my 2 SL's are showing as WM:1

I don't really understand what's going on but it's all sorted now!

 

 

Disabling WIFI on the Arc shuts down the 5 GHz private connection to the Sub.  You need to have WiFi turned on for the Arc in order for it to connect to the Sub. 

If you still have anything set to ‘Disable Wifi’ you have not got it properly sorted.  Please confirm what is currently wired and what has ‘Disable WiFi’ checked.

The Arc should be wired.  The surrounds and Sub should not be wired.  All devices should be set to ‘Enable WiFi’, including the wired Arc.  All devices should show WM=0 in About My System.

Userlevel 3
Badge +5

@John B - I have ticked 'Disable WiFi' but only on the Arc.

 

I thought it only applied to the Arc, that's why I did it.

 

EDIT: I have also disabled WiFi on my Sub and now my 2 SL's are showing as WM:1

I don't really understand what's going on but it's all sorted now!

 

 

Disabling WIFI on the Arc shuts down the 5 GHz private connection to the Sub.  You need to have WiFi turned on for the Arc in order for it to connect to the Sub. 

Doh, that's why as I forgot that the Sub uses 5 Ghz band!

Userlevel 3
Badge +5

The Arc should be wired.  The surrounds and Sub should not be wired.  All devices should be set to ‘Enable WiFi’, including the wired Arc.  All devices should show WM=0 in About My System.

Why should the Sub not be wired?

Even though I have discovered my 'mistake', does it matter that I have 2 wired devices now?

 

If I only have 2 devices connected via ethernet (arc and Sub), how would all devices be showing as WM:0 if the 2 SL's are connected via WiFi, surely they would show as WM:1 which is what I have on my system?

I am confused now 🤔

If the Arc was originally set with ‘Disable WiFi’ the only way a wireless Sub could connect would be via the home WiFi. This would give the impression of being online but the Sub audio could routinely falter due to the excessive latency on the roundabout trip from Arc to Sub causing buffer underflow.

As already noted the Sub has to have a wireless direct connection to the Arc’s own 5GHz radio. Or the Sub can be wired if the Arc is wired.

The above would also apply for the surrounds.

The Arc should be wired.  The surrounds and Sub should not be wired.  All devices should be set to ‘Enable WiFi’, including the wired Arc.  All devices should show WM=0 in About My System.

Why should the Sub not be wired?

Even though I have discovered my 'mistake', does it matter that I have 2 wired devices now?

No, you’re fine. So long as the Arc’s ‘WiFi’ is enabled the surrounds can talk to it.

 

Userlevel 3
Badge +5

Just to say chaps, you really know your technical stuff.

For the record, I have gone back to a wired connection for the Arc only.

I didn't realise for a number of hours that the Sub wasn't working after disabling the 5 GHz band lol

As you can probably guess I am not technically minded and what I like about this forum is no one takes the mickey!

OK.  Your confusion is mostly because you are not distinguishing between WiFi (the wireless connection created by your router) and ‘wireless’ (which also includes SonosNet and direct device-to-device communication).  To be fair, the Sonos app is unhelpfully lax in its use of these terms.

As soon as you wire just one Sonos device the whole Sonos system connects wireless devices using SonosNet, NOT WiFi.  The WM=0 indicates that the device is connected by Ethernet or wirelessly using SonosNet.

Actually, that isn’t quite correct for surrounds and Sub in a HT system.  These connect to the main HT device (e.g. Arc) via direct routing over 5GHz (NOT your router’s 5GHz Wifi).  At least they will do if their radios aren’t disabled, which is what you inadvertently did.

If you still have the Arc wired but with its radio disabled, and the surrounds are connected via your WiFi (WM=1) this is going to give you latency in the surrounds and they are very unlikely to operate in a stable and reliable way.

It is incredibly unhelpful that the app uses the terms ‘Enable / Disable Wifi’ for something that actually disables SonosNet.

As you can probably guess I am not technically minded and what I like about this forum is no one takes the mickey!

When people come on here seeking understanding and help, there are lots of people happy to help.  It’s when users come on with ‘Sonos is a useless system and the company is run by imbeciles’ that politeness may go out the window (at least in my case!)

Userlevel 3
Badge +5

The Arc should be wired.  The surrounds and Sub should not be wired.  All devices should be set to ‘Enable WiFi’, including the wired Arc.  All devices should show WM=0 in About My System.

I have my setup exactly as you stated above.

I am not touching the settings any more lol

I think it was @ratty who once suggested something along the lines of, that switching off WiFi on a Home Theatre master product, when it’s bonded surrounds or sub are uncabled and connected over WiFi, should perhaps just disable its 2.4Ghz adapter only, leaving the 5Ghz adapter available to still do its job… I think that’s a really good suggestion and would certainly have stopped the problems seen by the OP in this thread. 

Userlevel 3
Badge +5

If you still have the Arc wired but with its radio disabled, and the surrounds are connected via your WiFi (WM=1) this is going to give you latency in the surrounds and they are very unlikely to operate in a stable and reliable way.

It is incredibly unhelpful that the app uses the terms ‘Enable / Disable Wifi’ for something that actually disables SonosNet.

Sorry to bring this thread back to life but I had to comment after reading your comment about latency as I also noticed occasionally that my surround speakers were producing sound a fraction of a second behind what the Arc produced.

Now I know why!

I also agree with you that Sonos's description of WiFi is somewhat misleading as apparently it is referring to SonosNet which is why I disabled the option on the Arc in the first place!

Cheers 🍻 

Userlevel 3
Badge +5

As you can probably guess I am not technically minded and what I like about this forum is no one takes the mickey!

When people come on here seeking understanding and help, there are lots of people happy to help.  It’s when users come on with ‘Sonos is a useless system and the company is run by imbeciles’ that politeness may go out the window (at least in my case!)

I have only had Sonos products for a number of months and I have found the sound quality excellent and I have no problem with trying to resolve the occasional problem encountered usually caused by me lol