Answered

Sonos disconnects from Sony TV

  • 8 October 2022
  • 3 replies
  • 712 views

I’ve got a Sony X95J and connect my Beam Gen2 via earc.   The problem I have is the TV no longer recognizes the beam after I use the beam for non-tv purposes.

For example:  when the TV is off, I play/stream music (Amazon Music) on the beam.  When Im done, I shut the music off.  When I turn the TV on to watch TV, only the tv speakers work, and no sound comes from the beam.

The only way to get the beam to work again is to unplug the HDMI and power cable from the beam, then replug it back on.

Any ideas?  this is becoming annoying.  I had a decent soundbar prior to this, but wanted a Alexa compaitable device to control my smart devices and play music.  

 

icon

Best answer by GuitarSuperstar 8 October 2022, 18:02

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 7

I would disconnect the Beam from the TV and redo the TV Setup process in the Sonos app. Be sure Bravia Sync is enabled on the TV and use the HDMI cable that came with the Beam. Also be sure TV Autoplay is enabled in the Sonos app.

Do you have any other devices connected to the TV?

Thanks… I do have a new Apple TV device connected to the TV

Bravia Sync is enabled, and autoplay is enabled in the app.  

 

I can try the HDMI cable but I doubt that’s it.  No issues with the other soundbar it replaced, and the cable is certified 2.1 - likely better than whatever came in the sonos box.

Userlevel 7

Thanks… I do have a new Apple TV device connected to the TV

Bravia Sync is enabled, and autoplay is enabled in the app.  

 

I can try the HDMI cable but I doubt that’s it.  No issues with the other soundbar it replaced, and the cable is certified 2.1 - likely better than whatever came in the sonos box.

Try the Sonos cable. It tends to work better than any other cable with Sonos devices. If that doesn’t make a difference, try disconnecting the Apple TV. It might be causing some interference.