Answered

Sonos Beam Not Connecting To Sonos App

  • 17 February 2023
  • 4 replies
  • 594 views

Badge

Sonos app failed to connect to any components my Sonos System (Two Beams - Gen 2  & 1 Move).

Followed diagnostic instructions to turn off all 3 speakers, but one of the Beams did not re-connect.  One Beam successfully connected, as did the Move.

Best Buy - Geek Squad is returning tomorrow morning to troubleshoot this latest connection failure.

I’m beginning to think that this Sonos purchase was a very bad idea.  I cannot trust it to work properly, it has been unstable and not dependable.

 

Every time I open the app, I’m fearful something else will go wrong.

 

Not a very healthy way to live!

icon

Best answer by Corry P 21 February 2023, 10:53

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7

Is either Beam close enough to wire one of them directly to the router with an ethernet cable?

Badge

Thanks for the reply.

 

I’m on a condo WiFi network.  

 

Fortunately, running the diagnostic a 6th time did the trick.  Don’t understand why it took so many attempts though.

 

 

@DMDJr,

Is it a case that the speakers are losing connection to the local network, or just a case that the mobile device/Sonos App is unable to view the speakers on the LAN …your post is not clear?

If it’s the latter matter then it might be a ‘multicast device discovery’ issue, or perhaps something something like security software, VPN, Firewall, Anti-Virus software etc blocking the communication.

Are the devices ever playing when they do not show in the App? Are you able to ping the speakers across the LAN? Have you got another mobile controller device you can try?

It may help here too if you describe your network setup in a little more detail.

Userlevel 7
Badge +18

Hi @DMDJr 

Welcome to the Sonos Community!

I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports. It sounds like you may need to adjust some settings on your router.