Sonos Beam Losing Source

  • 23 April 2022
  • 2 replies

Recently got the Sonos Beam (Gen2). Bit annoyed that it requires an app to setup. An app that demands to know my location otherwise refuses to load. But anyway…

I setup the speaker, plugged in a mix of cables to get my TV connected

Beam > HDMI (included) > Optical adapter (included) > Aux converter (my own) > TV

Everything worked great. We were watching TV and I deleted the app.

Next day, I turn on the TV and there is no sound. The Beam has a solid white light and if I press the Play button it flashes orange. I re-downloaded the app, turned the speaker off and on, wiggled some of the cables… not sure what i did but it started working again. If I press the Play button it goes from a White light to a Green light, muting or unmuting the sound. All seems well. I deleted the app again… I don’t want it.

Next day. I turn on the TV and there is no sound. We’re back to White/Orange lights.

What am I doing wrong here? I just want to plug my TV into this speaker and have sound. Do I have to forever have this app on my phone tracking my location to make the speaker work??


Best answer by Madgick 24 April 2022, 16:56

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7

You don’t have to keep the app on your phone for the Beam to work with your TV. But you will lose the ability to stream music from the Sonos app and receive software updates for the Beam.

If I had to guess, the problem is probably caused by the aux converter.

If you keep the app installed on your phone and turn off the TV and turn it back on after a few hours, do you experience the same issue?

Hi GuitarSuperstar,

Thanks for replying, I reproduced the issue a few times, but I did manage to find a fix. Bizarrely, it seems if you want to find the settings for an individual device, you have to go into the App settings, then find the device listed there, then you get into its own individual settings.

Once you find that, there is an option called “TV Autoplay” that I turned on. Everything has been fine since then. I guess this would imply that while the Line In was not producing sound, the device tried to default to some fancy assistant mode or something. Now it lets the Line In device override whatever else is going on.

App once again deleted 👍 Everything working fine