Answered

Sonos Beam Constant Restarts with TCL Roku TV

  • 27 June 2022
  • 2 replies
  • 82 views

Hi.

I have a Sonos Beam Gen 2 and TCL Series 6 55” Roku TV (55R635) and I have them connected via eARC HDMI cable.

I’ve had the Beam for about six months and over the last two months I have to constantly unplug and replug the Beam to get sound going. I’ve tried three different HDMI cables to no avail.

I just completely reset everything with a new 8K HDMI cable, unplugged everything and waited ten minutes and reset from scratch. The Beam was found in CEC and everything was fine. Then I plugged in the cable box and xBox and then the Beam drops out of CEC, but the sound still worked. Then after the TV goes into sleep mode and if I want sound when I turn the TV back on, I have to unplug the Beam and then plug it back in and then I have sound.

I have a similar TCL Roku TV in another part of the house with a Bose soundbar and have never once touched it after initial setup, so I’m at a loss here.

Thanks.

icon

Best answer by GuitarSuperstar 27 June 2022, 15:38

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7

Have you tried disabling the CEC setting on the cable box and Xbox? On the Xbox, it should be called TV & A/V power options. Also, it is usually best to use the HDMI cable that came with the Beam.

Have you tried disabling the CEC setting on the cable box and Xbox? On the Xbox, it should be called TV & A/V power options. Also, it is usually best to use the HDMI cable that came with the Beam.

 

This worked - THANK YOU!!!!!!