Answered

Sonos Beam 2 lost connection with Samsung TV, which is connecting thru eARC

  • 14 November 2023
  • 48 replies
  • 1723 views

Background Info

  • Sonos App
    • Version 15.9
    • Sonos OS S2
    • Build 75146030
  • Sonos System
    • Beam Gen 2 ver159 build 75146030
    • Sub mini ver 15.9 build 7516030
  • Samsung TV QE75QN85BATXXU
  • Sonos Beam 2 connects with Samsung TV with eARC

 

Problem
- After TV is off & on, the TV will lost the connection of Sonos Beam and output the audio with internal speaker

 

Workaround

  • Power off the Sonos and Power on the Sonos. The TV will re-connect to the Beam.

Tried to reset the Sonos Beam or Power off sonos beam&TV + Disconnect sonos beam + Power on sonos beam&TV + connect sonos beam. But the problem still exists.

 

Please kindly advise how to resolve the issue

icon

Best answer by Sotiris C. 15 November 2023, 16:08

View original

48 replies

Userlevel 2
Badge +2

Does anybody know whether this issue has been resolved? 

No it's not, a few of us have just experimented with different settings mine being explained just below this. I've also purchased a remote power socket that I've also used to easily do a power cycle. But at the moment mine is stable with what I've changed below.

Thanks for the reply. My work around is using the optical output - irritating! 

My Samsung s90c to beam 2 has been stable for 3 days since the upgrade to v16.0 using EArc

Anyone else?

Userlevel 2
Badge +2

My Samsung s90c to beam 2 has been stable for 3 days since the upgrade to v16.0 using EArc

Anyone else?

No mine was stable but started the problem again after the update 

Tried this out overnight! Still same problem which is irritating to the extreme! Does anybody from Sonos have anything constructive to add to this conversation? Or they (Sonos) quite happy to market a product which is defective and does not perform to the specifications!

Userlevel 7
Badge +14

@A big fan BUT 

Hello,

I really understand the frustration of the situation, but imho the problem indeed is that there are NO specifications for HDMI CEC all manufacturers have to go with. CEC offers many options and each manufacturer provides some of them for its devices and does the implementation its own way. Some of them even without much accuracy what makes it more difficult. 
So the question from my point of view is who does the implementation in a most compatible way to other manufacturers. Difficult to blame someone in general…

 

Hi Schlumpf

interesting comment! Are you responding in a personal capacity or on behalf of Sonos?

Userlevel 7
Badge +14

Hi Schlumpf

interesting comment! Are you responding in a personal capacity or on behalf of Sonos?

Definitely just personal… but I stay in contact with some developers of HDMI hardware like eARC audioextractor used for Sonos devices. And they often have to „fight“ against the different implementation of CEC communication. 

Userlevel 2
Badge +2

Hi Schlumpf

interesting comment! Are you responding in a personal capacity or on behalf of Sonos?

Definitely just personal… but I stay in contact with some developers of HDMI hardware like eARC audioextractor used for Sonos devices. And they often have to „fight“ against the different implementation of CEC communication. 

I have had to turn the e-Arc off on my Samsung TV as the Sonos Beam Gen 2 is more reliable on just HDMI.

I've also got a Lindy CEC free adapter on HDMI 1 connected to my Amazon Firestick.

These tweaks seem to work a little better but certainly not fixed the problem.

I still have to do a power cycle every now and then.

How is this still not fixed?

I agree! Sonos seem to be absolutely silent on this! This will definitely affect my purchasing patterns and certainly will not get any positive recommendations until fixed.

Which at this rate may be never……

Userlevel 2
Badge +2

How is this still not fixed?

Not sure if it's the Samsung TV or the Sonos equipment that's been the problem but since the 16.1 Sonos firmware update last week & the Samsung 1622 update just before that it's been behaving. I've also switched back HDMI e-arc connection 🤞

Still not fixed. Shame on Samsung and Sonos.

Userlevel 7
Badge +14

Still not fixed. Shame on Samsung and Sonos.

Not helpful at all to give support. But maybe just wanted to rail against Sonos and Samsung.

Userlevel 6
Badge +14

Hello everyone,

While we at Sonos and the Samsung team are working hard for a fix on this issue, there were reports from customers that an update on their Samsung TV resolved it.

Those reports mention that the update on the TV didn’t happen automatically, customers had to manually go to the Samsung website and download the newer version.

I would suggest for our users who experience this problem to please, manually update your Samsung TV and see if this resolves it.

You should be able to find out how to update your TV to the latest firmware via the official Samsung website here.

Feel free to come back on this thread and reply with the results.

We appreciate your patience as we are working together with Samsung to resolve the Sonos Beam (Gen2) disconnection with Samsung TV’s.

I have the latest firmware version on the samsung s95b v1622. sonos stil loses connection with e-arc the only solution is power of the sonos and power on. there are also sounddrops now and then. I like the sound of the sonos and the view of the samsung but with the bugs its very annoying.

Userlevel 2
Badge +2

Hello everyone,

While we at Sonos and the Samsung team are working hard for a fix on this issue, there were reports from customers that an update on their Samsung TV resolved it.

Those reports mention that the update on the TV didn’t happen automatically, customers had to manually go to the Samsung website and download the newer version.

I would suggest for our users who experience this problem to please, manually update your Samsung TV and see if this resolves it.

You should be able to find out how to update your TV to the latest firmware via the official Samsung website here.

Feel free to come back on this thread and reply with the results.

We appreciate your patience as we are working together with Samsung to resolve the Sonos Beam (Gen2) disconnection with Samsung TV’s.

Do you have any idea when the latest update will become available through the TV update rather than downloading to a usb flash drive. If there is an update surely it  should be made available the normal way through the TV automatically 

Userlevel 7
Badge +14

@Ummagumma 

Imo you should ask Samsung for that. 
They are responsible for their devices updates and ways of distribution. 

Userlevel 2
Badge +2

Please ignore my last post it's being discussed on both Samsung and Sonos community and I posted on the wrong one sorry my bad

Badge

Latest update from Samsung 1622 doesn't resolve the issue, it's just as bad as it ever was. 

Badge

Hello everyone,

While we at Sonos and the Samsung team are working hard for a fix on this issue, there were reports from customers that an update on their Samsung TV resolved it.

Those reports mention that the update on the TV didn’t happen automatically, customers had to manually go to the Samsung website and download the newer version.

I would suggest for our users who experience this problem to please, manually update your Samsung TV and see if this resolves it.

You should be able to find out how to update your TV to the latest firmware via the official Samsung website here.

Feel free to come back on this thread and reply with the results.

We appreciate your patience as we are working together with Samsung to resolve the Sonos Beam (Gen2) disconnection with Samsung TV’s.

Unfortunately your request for patience is a quite insulting as this issue has been going on for 8 months. We've spent a lot of money on Sonos and Samsung equipment and frankly expect much better service. This problem should not have been allowed to carry on for so long and frankly I question your actual commitment to resolving this as you certainly haven't been very forward in acknowledging the issue in the first place. How can it take 8 months to diagnose and fix an issue? 

Badge

Well 16.1.1 is out, rebooted TV (holding power button down until TV logo appears) and back on TV speaker so that looks like yet another month without a fix.......will see if it goes overnight again when in standby....doesn't look hopeful though.

 

No changelog for 16.1.1 currently.

This is the exact issue I’ve been experiencing since moving from my old Sony TV to my SAMSUNG QE55S90CATXXU. Glad to see that I’ve not been suffering alone in some ways, but Sonos\Samsung need to get this fixed. Running latest firmware on both Sonos Beam G2 & SAMSUNG QE55S90CATXXU but issue still occuring.

Reply