Answered

sonos arc no tv audio - Chromecast hd / Vizio m65-e0

  • 4 December 2022
  • 7 replies
  • 115 views

Hi all thx in advance for any direction -

 

My setup - Vizio m65-e0 4 HDMI inputs 1 being HDMI 2.0 ARC supported 2-4 only HDMI 1.4.

Google chromecast HD

Sonos Arc

The Arc is plugged into HDMI 1 Chromecast is plugged into HDMI 4

During setup of the sound bar everything seemed to go smoothly - the Arc connected to the tv without issue.  In the system menu - CEC - both the Arc and the Chromecast are recognized.

If I leave the audio to tv speakers the Chromecast will play audio out of the tv and the Google remote will control the tv volume.

If I disable tv speakers in the Vizio menu the the Chromecast controls the Sonos audio and the tv recognizes the the audio is going to a different source however the Sonos puts out no audio.

The Sonos app says that the tv is playing audio and allows volume control that is recognized by the tv (displayed volume up or down)

So it appears everything is communicating and controlling as expected however without the audio coming through the Arc.

All firmware is up to date.

Note - I'm using an existing HDMI cable not the Sonos provided one. Failing any feedback/thoughts from the community that's my next step I think or trying the optical route that said I feel like there is a simple setting I'm missing / overlooking any and all help appreciated.

Dean

icon

Best answer by Sigma 4 December 2022, 20:24

View original

7 replies

Is "TV Autoplay” enabled in the Sonos App ‘Settings/System/[Arc Room Name]’?

Check the audio output is set to the HDMI-ARC port and Dolby Digital and ensure that ‘DTS TruSurround’ is ‘off’ and see if that sorts it.

Hi Ken thx for the reply.

 

I can confirm tv autoplay is set to on.

As far as audio output my tv has afaik a speakers option which is on/off/auto. On takes input from HDMI 4 (Chromecast through tv speakers). Off / auto seem to try so output to Sonos (tv displays "audio system)

For TruSurround I did not see any options for that on the tv, Chromecast or Sonos.

Did I miss something?

Thx again 

Dean

 

 

https://cdn.vizio.com/manuals/kb/mxxexmanual.pdf

I have only quickly glanced through the TV user-manual , it was just a case that that codec was mentioned on Page 20 - see attached screenshot and the above link, it mentions DTS TruSurround - I would just switch that off and look to output Dolby audio instead…and in the digital sound out choose ‘bitstream’.

See the attached screenshot too regarding setting the audio-out to ‘fixed’ volume.

I assume you have enabled CEC control already and that the TV sound out is set to output it’s audio via the HDM-Arc port?

Thx Ken - that image helps.  I've attached my tv settings.  Which match your suggestions.

 

 

From the system menu CEC is set to ARC only. Other options are enabled or disabled. 

 

Any other thoughts.

 

 

 

 

Maybe see if switching off the speakers makes a difference.

Just as a quick test too, see if switching the digital sound out from Bitstream over to Dolby Digital or PCM actually gives you stereo audio out to the speaker.

My thoughts though at the moment is it’s something to do with the fact the TV default audio is based on DTS audio but lets see what happens when you perhaps try the suggestions above.

 

Thx for sticking it out with me here👍

So I went ahead and took the tv down and swapped the HDMI cable to the new one and low and behold it works.  What a pain.

So thx again for your help now off to source a new longer HDMI cable.

 

Cheers

Dean

Thx for sticking it out with me here👍

So I went ahead and took the tv down and swapped the HDMI cable to the new one and low and behold it works.  What a pain.

So thx again for your help now off to source a new longer HDMI cable.

 

Cheers

Dean

No worries Dean, I’m always happy to try to help. Nice to see you found the problem too. 👍

Reply