Sonos Arc dropping sound with HBO MAX

  • 14 August 2021
  • 19 replies



About 2.5 months ago I bought a Sonos Arc to go along with a Sony A80J. Everything is great except one very specific situation. When watching on HBO MAX and the show is in Atmos the sound will cut out every few minutes. In my case, the sound will not come back unless I turn the television off or switch the audio source back and forth. However, once it is back it will cut out again a few minutes later. I can watch movies/shows in Atmos on HBO Max with the TV speakers without any issue. I don’t have any issues watching shows in Atmos on any other app (e.g., Netflix, Disney+) or in 5.1 on HBO MAX or otherwise. Any suggestions on how to fix this problem? It is really frustrating because I want to take advantage of the Arc when a show is available in Atmos. 

Thanks for you help.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

19 replies

Userlevel 7

Have you tried disabling eARC on your TV?



Thanks for the suggestion. I have not tried this, but if I do disable eArc won’t I not be able to take advantage of the Atmos sound? I thought eARC and HDMI 2.1 were both required to receive Atmos sound.

Userlevel 7

You don’t always need eARC if you are using the TV’s native apps. eARC is mainly required to play Dolby Atmos from external devices like an Apple TV 4K or Blu-ray player.


I looked and eArc was off. I actually changed it to auto to see if that fixed the issue - it did not. I changed it back to off and still have the issue. I let the issue play out and it lasts for about 20 - 30 seconds and then the sound comes back. But, a few minutes later it will happen again. It happens at random times not always the same spot. Any other thoughts? I appreciate the suggestions. 

You can download the tiktok videos from Try it right now.

Userlevel 7

Can you post photos of your TV’s audio settings? Are you using the HDMI cable that came with the Arc?


Sure. Here are the photos. Let me know if you were wanting to see something different. I just switched out the HDMI cable to one that is much more expensive. But, the problem persists. 



Userlevel 7

Try changing A/V Sync to Off, Digital Audio Out to Auto 2, and set Pass Through Mode to Auto. Test each setting individually and try different combinations to see if it makes a difference.


Thanks for the additional suggestion. so, far I have tried:

A/V Sync to Off - still problem

Auto 2 - still problem

Pass Through Mode to Auto - still problem

I will try combinations and let you know if I find a different result.


As an update: I called Sonos support today who indicated the issue is with the TV  (i.e., Sony). I called Sony who changed the settings by changing the audio from Dolby Digital Plus to Dolby Digital. This seemed to “fix” the issue on HBO Max but it did so by preventing me from hearing in Atmos. So, a solution but not a great solution. I just have to hope Dolby Digital 5.1 through the Arc is better than Atmos through my TV. I’ll change back to DD+ when watching other apps. At this point, unless HBO Max comes out with a patch, I’m not sure what else to do. 

What device is HBO Max coming from? For instance, WarnerMedia has indicated that they’re rewriting the entire HBO app from the ground up on Apple TV, due to issues that are ongoing on it.

To quote from that article: "We're going to replace every single connected TV app in the next four or five months,"


I saw that and it got me excited. I’m watching through the native app on my Sony TV. I read they will replace the Android app (which runs on Sony) too but after the Apple TV app. I hoping that solves the problem. 

Fingers crossed for you, for sure!

I’m confirming the exact same issue on the exact same setup. Just to clarify that it isn’t an isolated incident.


Thank you for confirming you have this same issue. When I spoke to Sony their solution was to turn of Dolby Digital Plus. This defeats the purpose of having a soundbar with Atmos but it did work. I just had to listen to the movie in DD 5.1. I’m still hoping HBO upgrades the app and it somehow fixes the issue. 

I came here looking for this exact information. I have the same television and arc as you and last night tried watching the new matrix movie.  The sound cut out every few minutes and eventually I gave up. 
Strangely it does not happen when I’m watching Curb Your Enthusiasm (only other thing I have watched on HBO Max). 

Any update on your end with this problem?


I’m sorry you had issues watching the Matrix. I actually recently figured out a solution by accident but, unfortunately, it is an expensive solution (and I’m not really sure why it works). Within the last month, I added a Sub and two One SLs to my system and, magically, the problem went away. When I watched Dune a month ago I still had the issue but it was fixed when I watched the Matrix. The alternative fix which will work with your current set up - but won’t let you watch in Atmos - is to go to the Sound and Audio settings and change it from Dolby Digital Plus to just Dolby Digital. That will force the sound to be 5.1. When you do that you will be able to watch the Matrix. The sound should still be good but not as could as it can be. 

In terms of why you don’t have an issue with Curb Your Enthusiasm, it’s because its sound is 5.1 and not Atmos. The only time you will have issues you will have on HBO Max are when the show streams in Atmos. 

Thank you I appreciate the quick reply. 

I already have the sub and two One SLs. I purchased them all at the same time when I purchased the television this summer.  There were a few other incidents of the sound cutting out during movies but I don’t use HBO Max often so I didn’t put two and two together.

I coincidentally also have an apple tv (I hate the interface and don’t like to use it) so I hooked that up and downloaded HBO Max and was able to watch The Matrix with no issues on sound.  Thank you!

Very random issue, I’m glad I found this thread. I hope they fix this through the google interface cause I don’t want to keep the Apple Tv hooked up but can’t imagine watching movies like Dune without the proper surround sound working. 

On another note, was super disappointed in The Matrix Resurrections.  I couldn’t even finish it. 


Interesting. I’m glad you were able to figure out a work around, but I’m amazed we now how the same set up and I no longer have the issue and you do. Since that is the case, one thought is that you may want to re-do the Trueplay or something related to the set up to see if that fixes the issue. Otherwise, I’m at a bit of a loss for what is the cause.

It is a random issue and, FWIW, the only streaming app that it occurs on is HBO Max. So, if you don’t use HBO Max much then you should be fine. 

The only other fix I can think of, which may be slightly better than using your Apple TV (but still annoying which is why I didn’t do it even though I could have), is to use a Roku stick. The sound may work better through the Roku than through the Google TV app. 

Sorry the movie was disappointing.