Ray support on an older Samsung TV 3D LED 46" UE46C7000WP

  • 10 September 2023
  • 9 replies

My Ray doesn’t seem to work with a Samsung TV 3D LED 46" UE46C7000WP. The tv doesn’t have the same optical audio plug of the ray (TOSLINK) but rather a mini TOSLINK, so I bought an adapter on Amazon but the Ray won’t work still. I have tried to play with settings (and of course selected external audio on the TV) but it won’t play still.

The ray works with airplay on my Apple TV so that’s definitely not the problem.


Any idea how to fix? Is is the tv too old (I guess it’s about 10 years old)



Best answer by Lorentzzz 18 September 2023, 12:57

View original

9 replies

Stupid question: You have inserted the miniTOSLINK into the TV’s optical out jack? According to the manual the 3.5mm analog outs are pretty close by and it would be easy to mistake one for another... Check at the Ray’s end for a red glow at the end of the cable.

Yes the out is correct, I have tried the other one too just in case.

What do you mean by a red glow at the end of the cable? You mean on the actual optical cable or on the ray once you connect it? In any case I can’t see either

At the opposite end of the cable from the TV, when the TV is on. Remove the cable from the Ray first, obviously, and stare into the end of the cable’s connector. 

If you can’t see any red when looking onto the end of the fiber then there’s no optical carrier coming from the TV. Either the TV socket is incorrect/faulty (most likely) or there’s something wrong the cable (least likely). 

Optical cables usually ship with little caps on the ends.  Make sure you remove the caps before using. 

Caps were removed, and I checked even in the dark but I dont see a red light on the optical cable.

Is there a reliable way to test if the cable is the problem? On the cable description says the mini-TOSLINK is supposed to work with Mac laptops too, I tried to plug it on a MacBook Air and no red light either

If you can get around the back of the TV you might be able to look down the barrel of the miniTOSLINK socket. See if there's a red light there. 

Otherwise simply try a different cable?

MiniTOSLINK looks more like a 3.5mm jack, and there’s no light coming out of the socket. 

I have ordered a different adapter (miniTOSLINK to TOSLINK) so I could use the SONOS cable instead of the miniTOSLINK to TOSLINK cable I ordered off amazon. No luck with that either. 

Seems like the TV (or the Ray?) doesn’t support miniTOSLINK to TOSLINK connection at all 

It sounds like the TV hasn’t activated its optical output. Is there a setting somewhere in the menus?

Yeah that might be the case.

On the audio out menu I have selected external speaker but nothing happens, I have checked other menus but couldn’t find anything relevant, will check again expert settings once I’m back home tonight, but the TV is old and menus are pretty limited (ie. different from these)

Guess if I can’t find any settings fixing it I need to contact Samsung support about it, right? maybe is some hidden setting they can help me access