Problem with grouping to Arc

  • 30 November 2022
  • 5 replies

We have an open-plan living/dining/kitchen space.  On one side I have an Arc, with two PLAY:1 speakers as surrounds. I have a Samsung TV with eArc, all that works perfectly.

For some time I have had a Sonos speaker in the kitchen area so that when cooking, I can group it to the Arc and hear the TV sound without having to turn the living room speakers way up. It’s been working fine for months… but not now.

I am getting dropouts so badly that I cannot bear to use the kitchen speaker. I simply cannot figure out what has changed. My WiFi coverage is good (I have Unifi boosters around the flat). The kitchen speaker (a Sonos One) works perfectly when solo or grouped playing other sources.

I have played around with the Group Audio delay, it doesn’t help, and as the speaker is effectively in the same room as the Arc+Surrounds it’s’ not very desirable introducing a delay. I’ve tried using a Sonos Roam instead of the One. Same behaviour.

Any suggestions on how to troubleshoot or fix this would be much appreciated.



Best answer by Airgetlam 30 November 2022, 23:31

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7
Badge +17

Sonos and smart wifi set ups are not always a good match. Does the problem also occur if you'd cable connect the Arc to the first Unify node or your router?

I have no choice but to use AP’s because despite living in a 2 bedroom maisonette, I cannot get decent wifi coverage through all the rooms without them.

It did work before without the arc being wired, but I will certainly try it out and report back 


Connecting the arc by cable (and disabling Wi-Fi on it to ensure cable being used) didn’t help unfortunately .

However in poking around in the UniFi controller app, I discovered that despite the description of the Wi-Fi connection to the Sonos One as ‘Excellent’ the signal was -78db (not sure how that could still be excellent but I’m fairly novice in this field). It was not connected to the best AP and I managed to force it onto another one, it now shows a -43db signal and appears to be working ok.

fingers crossed it doesn’t reconnect to the other one…

Please don’t disable wifi on the Arc. It uses that signal path to connect to the Sub and the surrounds. 

Thanks for that info which I didn’t know. In this case I only disabled WiFi on the Arc temporarily to be sure Ethernet was being used instead. As it didn’t resolve my issue anyway I re-enabled wifi and removed the cable.