Answered

Older SonosPlay1 and Playbar loses connection over Wifi after a while

  • 27 December 2020
  • 5 replies
  • 289 views

Userlevel 1
Badge +2

I have been troubleshooting a rather strange behaviour with my SONOS speakers.
I've noticed that this behaviour started somewhere between last week this week.
I do have AutoUpdate enabled on both SONOS as Ubiquiti.

I got:

2x older Play1
2x newer PlayONE
1x Playbar

 

The behaviour is that somewhere during the day (i think in the night) both the 2 older Play1 and Playbar loses connection with my home network.
My 2 newer PlayONE speakers work fine and the rest of stuff on my network keeps working without a hitch.
I have tried restarting the speakers but that didn't help.
Tried wiping them back to factory defaults (powering up while holding PLAY button). But then they don't connect to the network at all.
The only thing that works is when I reboot my router. So the next day when it happened, I went in and cleared the DHCP lease of one of the speakers but when it rebooted it still didn't get connected to the network.

I'm running out of ideas where to look.

 

I am running a Ubiquiti network.
2x Ubiquiti NanoAPs
3x Ubiquiti POE 60W switches
1x Unifi USG 4
1x Unifi Cloud Key controller

icon

Best answer by ViperXL75 8 January 2021, 11:14

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 6
Badge +17

Hi @ViperXL75.

Thanks for the update and immediate response. 

I’m glad that everything worked out thanks to your effort in doing an investigation on what may have caused the issue. Updates on the router may have changed some settings necessary for Sonos to function seamlessly with your network. Thanks for sharing what was done to fix your issue so other members of the community who might have the same issue as yours may find this post handy. I do hope you continue to love and enjoy your Sonos.

Please do not hesitate to reach out or create a topic if you have additional questions or concerns. here in the community, everybody is welcome to ask and help out.

Thanks,

 

Userlevel 1
Badge +2

Seems I found the culprit of the problem.

It looks like an update that I received earlier has sent  my machine into a crazy state.

So I reset both the Ubiquiti Controller as the Ubiquiti Router back to the factory defaults.
Then I proceed to do the necessary settings for my network to start working again and the problem disappeared.

I have disable auto-updates on both Sonos as Ubiquiti.
Next time an update breaks up stuff, I want to be there to know what was the last action that might have broken stuff.

 

The issue is solved.

Thanks for the quick answers.

Userlevel 6
Badge +17

Hi @ViperXL75.

Thanks for the detailed and immediate response.

Try going through the topic I have shared above which was created by @controlav. The topic discusses the use of multiple Access Points, Mesh, multiple routers, etc and what to do and how to configure for Sonos to work seamlessly. Feel free to ask questions and comment on the topic. I would also like to share with you another guide about Sonos system requirements where it discusses there an important information about Unsupported network setups and devices.

  • Wireless internet connections such as satellite, mobile hotspots, or LTE routers
  • Guest networks or networks that use a portal login page
  • Networks using wireless range extenders 2
  • Ethernet over Power (EOP) devices

I hope this helps.

Please let me know if you have further questions or concerns. I’ll be more than happy to help you out.

Thanks,

Userlevel 1
Badge +2

Hi @Paul A 

Ah thanks for the quick response!
I'm not working on a Mesh network. I just have my AccessPoints connected via Cable.

I'll give a response on each of the points mentioned below:

  • Have each access point have their own unique Wi-Fi name as so you and your mobile controller do not get confused about what and where to connect to access your Sonos system.
    - Interesting point, 
     
  • Disable Wifi Capabilities of the Main router that provides connection directly to your ISP or internet provider.
    - The Ubiquiti router-firewall Unifi USG 4 does not have wifi capabilities
     
  • Disable the DHCP or IP-address generation of the Access point and only allow the main router to generate the IP-addresses to avoid IP-address mismatch or IP-address duplicates.
    - I agree and it is already disabled
     
  • Wire a Sonos device to one of the routers/access points to get them to stay on a single network (having each access point have their own unique WiFi names)
    - This will be a bit complicated since Ubiquiti system is built to deal with multiple accesspoints throughout an Office. The system creates the same SSID on multiple APs but on different WifiChannels. In that way you can roam from one AP to another while you walk through a building.

 

The thing that is puzzling me is that I thought that the DHCP was giving problems so I changed it to refresh IP lease every hour instead of every 24hours. Just to see if the Sonos speakers would die again at night or within the hour. They still worked fine during the day and died at night. I've changed the DHCP settings back to 24hours.
I know also that at night the AccessPoints will shut off their SSID and do a quick wifi-scan to check if the channels that they use are still the best channels. I'll disable that mechanism and see if that helps.

 

I do want to point out though that this has worked without issues for the last couple of years and that my problems only started recently.

Userlevel 6
Badge +17

Hi @ViperXL75.

Welcome to the Sonos community and thanks for bringing this to our attention. I totally understand the frustrations of getting Sonos to work on a Mesh network. Allow me to help you out by sharing some information that discusses about Sonos working on mesh systems so we can better understand how mesh system works and how Sonos works and what needs to be done for Sonos to work.

 I would suggest reaching out to the manufacturer of the mesh system so that the mesh system can be configured in bridge mode or access point mode or which option best fits your preference (the main objective is to disable the mesh from generating their own IP-address).

  • Have each access point have their own unique Wi-Fi name as so you and your mobile controller do not get confused about what and where to connect to access your Sonos system.
  • Disable Wifi Capabilities of the Main router that provides connection directly to your ISP or internet provider.
  • Disable the DHCP or IP-address generation of the Access point and only allow the main router to generate the IP-addresses to avoid IP-address mismatch or IP-address duplicates.
  • Wire a Sonos device to one of the routers/access points to get them to stay on a single network (having each access point have their own unique WiFi names).

 Let me share with you a topic in this community that discusses multiple routers. You can share and ask questions or comments on that topic if something is not clear. 

I hope this helps.

Please let me know if you have further questions or concerns. I’ll be more than happy to help you out.

Thanks,