Nothing is working - last effort before getting rid of it all

  • 12 November 2020
  • 9 replies


I have a Beam and 2 IKEA Symphonisk speakers. The Beam has been working fine for over a year without ever touching it connecting seamlessly to Apple Airplay on my phone, iPad or AppleTV. Then came the iOS14 update.Since then there is only problem and the speakers became dust collectors only. I’m at the point to throw them out all together and opt for another system.

Here is what I have now and what I have done trying to connect them all:

-Iphone11 with iOS14.1 and iPad with iOS14.1 I use Sonos S2 app on the phone. 

-Beam and 2 Symphonisk on Wifi, but unable to connect to them through the app. I’ve already reset the router twice, worked a bit then unable to connect again. I reset S2 app. 

-I sign into the S2 app but my system is not recognized. Blank and not highlighted. Then I click on “Select product” but it just searching for nearby products for over 5 min. I’m standing next to the speakers all plugged in. This is the same whether I try to log in as join existing system or set up new. 

BY THE WAY, on my wifi networks I’ve turned off “private address” as suggested by some. No matter what the app is not finding my system. 

Resetting a router every week surely cannot be the solution from Sonos. 


Any help would be greatly appreciated. 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

The key thing that I think you’re missing here is that it’s not just resetting the router….you need to have the Sonos devices unplugged while the router is being rebooted, otherwise they are not getting new IP addresses when they get plugged back in after the router is back up. They’re still holding on to the ‘bad’ addresses they were handed by the router before.

Alternately, and more permanently, you could choose to assign reserved IP addresses for your network devices in your router’s DHCP table, by looking for instructions in the router’s manual. If a router has gotten in to a state where it is handing out bad IP addresses once, it’s possible it could do so again, and due to the fact that each time that Sonos updates it’s software, it forces the devices to soft reboot and request new IP addresses, you could end up being in the same state as before. 


Thanks Bruce, but I did that. All my devices were unplugged, reset the router and plugged them back in. It worked...For a week…. Then I did it again…. Then worked for a week. 

I ran the same Beam speaker on the same router for over a year without any issue ever. Given it was a different Internet network. Then I moved countries and networks. Otherwise nothing changed. My issues only started with the iOS 14, but maybe I’m connecting the wrong dots. 



Then rather than trying to address the issue anecdotally, I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it, or post the diagnostic number here for a Community Moderator to pick up.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, there are more options available beyond just the diagnostic analysis. 

@Tom_BP  - Could this be relevant?

‘With the release of iOS 14, Sonos requires the “Local Network Access” permission to be enabled in your device’s settings. For more information, see our article on Sonos app permissions.’


Thanks @John B. I saw that and made sure it’s set right. 


I’ve actually read through the threads and been trying to figure this out for weeks with no luck. Sometimes, completely randomly my app connects, but that’s probably only 10% of the times. Overall, the user experience has gone down dramatically and rarely use the speakers. 

Bit of a long shot this one, but as an experiment could you temporarily turn off the 5GHz wifi on your router and see if app connects better?


So unplugged everything, reset the routers and plugged it back again. Works for now, the problem is that this is the 3rd time I had to do this.

Userlevel 7
Badge +18

It’s not clear from your posts: have you reserved ip addresses? (It was recommended above by Bruce.) That should eliminate the need to keep unplugging/restarting everything. 


No, unfortunately, I have no idea how to do it.