Question

No Sound - AppleTV 4K + Sony TV + Sonos Beam

  • 12 August 2020
  • 1 reply
  • 1032 views

Pretty straight-forward setup: AppleTV 4K connected to HDMI 2 on my Sony TV. HDMI-ARC out of the Sony into my Sonos Beam. This was working perfectly.

Now, a mystery: I moved into a new home, hooked everything up in the same way as before (I think!) and now I can't get sound from the AppleTV to the Beam. My Sony TV is set to 'external speakers' (it did this automatically when I connected the HDMI cable from the ARC port to the Sonos. The Sonos itself is working otherwise (i.e. I can play music through it either via the Sonos app or by AirPlay).

Suggestions? I'm going mad!


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 5
Badge +16

Hi @brijazz.

Thanks for reaching out and welcome to the community!

I appreciate your detailed post outlining the issue as well as the troubleshooting steps that you did, let me help and try to figure this out.

First, I suggest adjusting the audio format on your TV and on Apple TV also to one of the audio formats supported by Sonos.

Then, check for firmware updates on both the TV and Sonos app. Install any available updates.

If that doesn’t help please submit a diagnostic report through the Sonos app, and reply with the confirmation number.

It can help identify what is causing the issue.

 

I’m looking forward to assisting you further from here.

If you have any other questions or run into any issues,  please do not hesitate to reach out.