Multichannel PCM with RTX3080 and LG C9

  • 8 March 2021
  • 3 replies
  • 266 views

Hello!

I have the following problem:

I want my ARC (with SUB and 2x One SL) to play Multichannel PCM in games over my PC (RTX3080).

I have my PC plugged into my TV (LGC9) over HDMI 2.1 and I cant get my Sonos Setup to play 5.1 / 7.1 (only stereo).

I tried every possible setting on my TV and I know that it should be Passthrough with Bitstream selected. 

 

What am I doing wrong?

Can someone please help me? 

 

Kind regards

 

Some pics of my settings:

 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Do you have an Apple TV HD/4K cabled, or that you can cable, to your C9 TV to see if it outputs multichannel PCM 5.1? I’ve just tried it with the C9 and using the TV settings of bitstream and pass-through I have it working here (see screenshot). So my thoughts are it’s something on your connected PC (perhaps?) - Please note the Port you are using must be HDMI-eARC (I think) and not HDMI-ARC as the LPCM multichannel codec is uncompressed lossless audio and HDMI-ARC will only support a compressed lossy format, so ensure eARC is enabled too on the TV. 
 

Hope that assists.

Ah I now see ‘ein’ is ‘on’ for the eARC port in your TV settings screenshot - so it most likely is an issue with your PC, as the LG C9 TV definitely seems to pass-through the LPCM codec.

I would perhaps concentrate on the PC Settings. Also consider powering off/on all devices fully (not standby) between any change of settings to re-negotiate the HDMI handshake correctly, as sometimes that may help too. 

Ah I now see ‘ein’ is ‘on’ for the eARC port in your TV settings screenshot - so it most likely is an issue with your PC, as the LG C9 TV definitely seems to pass-through the LPCM codec.

I would perhaps concentrate on the PC Settings. Also consider powering off/on all devices fully (not standby) between any change of settings to re-negotiate the HDMI handshake correctly, as sometimes that may help too. 

First of all, thank you for your quick answer. I sadly dont own an Apple TV to test with. 

I have my PC (cable goes out of the RTX3080) plugged into HDMI 1 on the C9 and the ARC is plugged into HDMI 2 (Arc). I would assume that this is correct aswell.

But I dont really know what settings I could change on my PC to make it working.

In the screenshot it lists all audio codecs and also shows max channels of 8.