Loudness/speech enhancement/night mode

  • 29 November 2023
  • 33 replies
  • 416 views

Badge

Hi,
Just got myself an ARC and a Sub Mini.
When toggling the Loudness/speech enhancement/night mode on/off, nothing’s happening.
Do I need eARC to enjoy this feature?

I do have HDMI arc, but sonos could not find it, so I had to use the optical cable.
That’s okay, but just wondering if it has something to do with the HDMI.
Having said that, the loudness didn’t work in the store when they were demostrating it for me.
And that was through eARC.
Any tips?:)
Ken


33 replies

Perhaps try playing Dolby Digital 5.1 surround audio and then toggling the speech enhancement/night sound buttons on/off as that type of sound input usually benefits with these two buttons. I find them really noticeable at night time when trying to not disturb neighbours and for some shows with poor front centre channel dialogue - Some examples of surround sound audio to maybe try (randomly chosen) are…

  • Jack Ryan Series 4 - Amazon Prime
  • Mulan - Disney+
  • 6 Underground - Netflix

I should just add the type of wired connection between the TV and soundbar is not relevant here.

Badge

Thanks for your reply, Ken.

I don’t have Amazon or Disney, but I found 6 Underground on Netflix.
However it only popped up as Stereo PCM on the Sonos app.
So I had to go back in to my TV settings and choose HDMI for sound out, instead of optical.
Then it shows Doly 5.1. However there is a lag, so the sound is quite a lot behind the film.
This is the reason I had to choose the optical out yesterday.
Anyway, the speech enhancement/night mode still doesn’t work...even though it’s out of sync🤔

Which TV is it - make/model? Where is the Netflix app located, is it built into the TV, or on a device connected to the TV? If it’s on a separate device, then set the audio to ‘pass-through’ the TV ports, rather than being processed by the TV itself.

Badge

Yeah sorry, forgot to provide that info:)
It’s LG 55ub830v-zg
It’s kinda old TV, but it does say HDMI arc on the port and the TV has the latest update.
However the Sonos app never found the HDMI, so I had to use the optical.
I watch Netflix through Apple TV 4K.
I tested HBO and a few other apps. They all lag a bit...but not as much as Netflix.
I can’t find a way to “pass through” the audio on the Apple TV. “TV Speakers” is the only choice that pops up as alternatives.

 

It’s not an Apple TV setting - it will be in the ‘sound out’ settings on your LG TV - it maybe set to Auto. Change the HDMI-ARC port (when in use) to pass-through. That’s if the TV has that option.

Also with some older LG TV’s there’s an option to bring the audio into sync with the video on screen. You need to perhaps consult the user manual for the TV. 

I assume on your Apple TV you have switched off Dolby MAT Multichannel LPCM audio output too and just using Dolby Digital 5.1? (Audio Format/Change Format = ‘ON’)

Badge

I see.
The only active choices I have on the TV is “AV sync. adjust”, which I have tried both on and off.

On the apple TV I can’t find any alternatives for Dolby🤔
 

 

Badge

Probably because my TV is not 4K.

Many of the screenshots you’re posting are not entirely relevant. If you enable the A/V sync on the TV, you still then have to go into that LG feature and adjust the lip-sync control to get it into sync (it’s a manual process IIRC). Also you still ideally need to consult your LG TV user-manual for the digital sound out pass-through setting, because if it is available, you can probably leave the A/V sync setting disabled.

Your Apple TV audio format is set to ‘Auto’, but I would switch that to ‘ON’  and select DD 5.1 as your TV has no eARC port, That’s really just so that its showing the correct DD 5.1 audio output. 

Probably because my TV is not 4K.

No, that’s not relevant here, DD 5.1 will work fine with a HD 1080p TV.

Badge

Yeah, I put the Apple TV on on Dolby 5.1😊
But now I don’t have sound at all. It seems like the arc has lost connection with the tv somehow.
I’ve tried everything for 15 minutes now. 
Trying to figure how to do the setup from scratch, but can’t find it in the app. 
I need some air now, so I don’t throw the whole bar out the window😂

Yeah, I put the Apple TV on on Dolby 5.1😊
But now I don’t have sound at all. It seems like the arc has lost connection with the tv somehow.
I’ve tried everything for 15 minutes now. 
Trying to figure how to do the setup from scratch, but can’t find it in the app. 
I need some air now, so I don’t throw the whole bar out the window😂

In that case, I suspect the Apple TV was probably only playing audio in PCM stereo before that setting change on your Apple TV. I would look closer at your TV audio-out settings, as it might perhaps be defaulting to DTS 5.1 audio rather than Dolby Digital 5.1. 

I really recommend that you check the TV user manual, to just see if that perhaps helps you to resolve the issue. You want the TV to play the Dolby Digital 5.1 codec and ideally to "pass-through" that digital sound-out audio from connected devices. If there is no "pass-through’ option to then try resolving the lip-sync issue manually with the LG TV A/V lip-sync features built into the TV settings. If the issues persist then it maybe best to speak with LG customer support.

There are other things you can do, using an audio extractor, but I don’t want to get you even more confused with going down that slightly more technical option to resolve the lip-sync issue.

Badge

Okay, sound is back.
I managed to break a piece of the optical output, so the cable was out.
Fixed it with some duct tape🤪

So the Apple TV is now on Dolby 5.1.
I don’t think the screenshots were irrelevent. I think that the “AV sync. adjust” is the one to use.
But it was a good tip that I needed to adjust it manually. I thought it was automatic.
So I put it at -5 now, which is max. And it is at least better. Not perfect, but livable. So thanks😊
The “Loudness/speech enhancement/night mode” - is still the same though.
But of course...sync was way more important.
 

Badge

 I would look closer at your TV audio-out settings, as it might perhaps be defaulting to DTS 5.1 audio rather than Dolby Digital 5.1.

TV audio settings are all greyed out as soon as I choose HDMI/Optical out.

 I would look closer at your TV audio-out settings, as it might perhaps be defaulting to DTS 5.1 audio rather than Dolby Digital 5.1.

TV audio settings are all greyed out as soon as I choose HDMI/Optical out.

Yes, that is usually ‘by design’ as the soundbar is now handling the audio.

Badge

Right. 
So there is no way to disable DTS.
Anyway, it shows Dolby Digital 5.1 in the Sonos app, so that’s probably fine.
It’s still out of sync. The only thing that I can adjust is “digital sound out” which is “auto” or PCM.
If I choose PCM, the dync is fine….but only stereo of course.

I would now perhaps just try fine-tuning things by ‘playing’ with your LG TV settings to get the best lip-sync possible. You could even speak with LG customer support and see what they suggest to improve the audio pass-through. See if there are any TV firmware/software updates too.

If the problem persists, then some LG users with older TV lip-sync issues and no TV ‘pass-through’ features, do sometimes opt to bypass their TV altogether by using an audio extractor/splitter, but that means buying hardware and inserting it into the setup between the Apple TV and your LG TV. Such a device extracts the audio from the Apple TV A/V signal and sends it direct to the soundbar, bypassing the TV altogether. 

The advantage of doing that, besides getting the lip-sync issue resolved, is that it will also upgrade the audio to provide Dolby Atmos audio playback from your Apple TV 4K. One such audio extractor is called the HDFury Arcana. You can perhaps read more about that product here…

https://www.hdfury.uk/product/hdfury-arcana/

Badge

Thanks, I’ve seen those.
Quite expensive. I guess I’d better go for a new TV at one point, and live with just stereo til that happens.
Too bad, I was buying the Sonos hoping it was just plug’n’play, but there’s always a weak link. In this case the TV😊

Also, now that you have switched the Apple TV to DD 5.1, perhaps go back and try the Optical connection once again, alongside the LG lip-sync feature adjustment, as you ‘might’ find you perhaps get better lip-sync using that connection instead. Some TV’s can ‘occasionally’ work better with that connection, although technically speaking, it has less bandwidth than the TV’s HDMI-ARC connection. These things though are always worth trying.

Badge

Yeah, I did. And it does work better. But it only gives me PCM/Stereo. The DD5.1 option is not there😏

Yeah, I did. And it does work better. But it only gives me PCM/Stereo. The DD5.1 option is not there😏

It should be🤔? - that must be a TV setting - check the TV’s "DTV audio” setting and set that to DD 5.1 - it might be under advanced or additional settings in the sound-out settings area of the TV.

Badge

I truly can’t find any settings at all except for HDMI out/optical.
Everything is then greyed out.
I have tried to read the manual but it doesn’t really help.

I truly can’t find any settings at all except for HDMI out/optical.
Everything is then greyed out.
I have tried to read the manual but it doesn’t really help.

I think you’re perhaps best to next speak with the Staff at LG customer support in your country and see if they can perhaps assist you with the TV setup, as it seems to perhaps be a TV setting or capability issue.

It’s hopefully just a few simple changes that you might need to make to get DD5.1 audio from your TV over its Optical connection - but they may say that with their older TV’s that the  only option is to use the HDMI-ARC connection to the soundbar, but perhaps see what they say.

Badge

Yea, I can try support at LG.

But knowing this product...is it odd that the ARC doesn’t reckognize my HDMI arc on the LG? Or is it something that many experience?

Yea, I can try support at LG.

But knowing this product...is it odd that the ARC doesn’t reckognize my HDMI arc on the LG? Or is it something that many experience?

Not something I’ve experienced, personally speaking, but what error do you get when you run the "TV setup" in your Sonos App?

Badge

It says something like “hdmi arc not detected”. “Try again”. And this goes in loop until I get the choice “i don’t have HDMI arc”. Then I connected the optical.

Reply