Answered

Keep losing sound when watching specific apps on my TV

  • 21 April 2023
  • 6 replies
  • 309 views

Hey,

 

I have a strange issue with my sound on Arc when I’m watching/using specific apps on my TV.

If I’m watching Youtube on my TV I keep losing sound every cca 30min for a couple of seconds and after that its back on. I can't guess what is causing it, because this happens just in a couple of apps and with others everything works flawlessly.
There also no issues when I’m listening/streaming music directly to Sonos without TV.

I was testing Youtube app like so that I switched back to TV speakers and after that there were no issues with the sound.

Even don’t know if I can submit diagnostics if this happens every cca 30min?

 

Problematic apps:

  • Youtube
  • T2 (local tv programs)
  • Voyo (local streaming service)

No problems with apps:

  • Netflix
  • HBO
  • Amazon Prime
  • Disney+

TV model: Philips 75PUS8506

icon

Best answer by Corry P 25 April 2023, 11:48

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7

If you haven’t already done so, set the Digital Out Format setting on the TV to Multichannel (bypass).

I have that set up.

Userlevel 7

If you use the Stereo (uncompressed) or Multichannel setting, does it make a difference?

Userlevel 7
Badge +18

Hi @matijajanc 

Welcome to the Sonos Community!

Given that only some apps are affected I’m really not sure what could be happening here, but if you haven’t tried it already, then I recommend unplugging your TV from power for at least 2 minutes.

If that doesn’t stop the issue, please test with all other HDMI devices disconnected from the TV and compare - if the issue stops, then it seems one of the connected devices was causing HDMI-CEC conflicts. Reconnect one at a time and test until you find the responsible device and disable it’s CEC functions - these generally relate to the TV’s volume, input selection and power. If you can’t find any such settings, you may need to fit a cheap CEC-Less adaptor.

I hope this helps.

Hey,

thanks for your help.

The last 2 days I was testing different Digital Out formats settings, with Stereo mode it was the same, but with Multichannel seems to be working but the sound is not that good as with Multichannel (bypass) setting :(
I’ll try to disconnect PS5 if that might cause problems.

There could be an issue with the service. I have a Firestick plugged directly into an HDMI port on my computer monitor, using Bluetooth for audio. No SONOS is involved here. Watching Amazon there will be occasional momentary audio mutes.