Forced to return product as the Sonos Setup wouldn't complete

I bought a Sonos Arc soundbar yesterday. I just got off a call with the support team member and even after one hour of troubleshooting unable to get past the Sonos setup. I am using the S2 Sonos app. 

This is what was done: 

  • First time connected to Wi-fi, setup failed with “Error 30” (tried this 4 times 2 times from an android phone, 1 time from an iphone and 1 time from an ipad) 
  • Tried with direct ethernet cable going to the router, got the error “Couldn’t connect to your Sonos” 
  • Did Factory reset at least 17 times, trying all possible options. 
  • Tried again Wi-fi, now after typing in the password the light on the Sonos Arc speaker would turn off, setup failed
  • The support tech asked me for diagnostic info, and he said he could not determine anything from that, why even have such a useless feature in the first place?


I just don’t know what to do other then be forced to return the product (honestly was so looking forward to use it) after 3 hours of wasting my time to setup the product, feel this is just not worth it. I have other important things to do than to fix problems for Sonos product, this is something their tech support team should be working on.  


Best answer by ratty 2 August 2021, 18:40

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Sounds like a network problem. Kindly describe your router/WiFi arrangements. 

I have an ATT Fiber connection - Arris BGW210 router, and a Linksys Velop wireless mesh network.

You probably have multiple IP subnets, breaking your network in two. Out of the box the Velop would contain another router, in its primary node.

Assuming the Arris router hasn’t been switched into bridge/modem mode I recommend you put the Velop into bridge mode.

The other option is to turn off the WiFi in the Arris router and connect only the Velop primary to it. 

@ratty, The wifi was never enabled on the Arris, its was always through the Velop. Another thing I am not able to comprehend is why directly connecting the ethernet cable won’t work either. I tested on my laptop and it was getting IP/DNS via DHCP, so why would it not work with the Sonos :( 

Where were you wiring the Arc? It wouldn’t work plugged into the Arris unless the Velop was in bridge mode. It ought to work if you wired it to the Velop primary (assuming that has a spare LAN port).

I was wiring the ethernet cable from the ARC directly to the Arris ethernet port, Velop is out of the picture here. 

As it stands that wouldn’t work. Either put the Velop into bridge mode or wire to the Velop instead.

Why is that, when my laptop can get an IP address/DNS, why do I even need the Velop in the picture here, in fact this is probably the most stable way to get connection since there is no Wifi involved, this is a direct ethernet connection to the ISP right ? 

Like I said, out of the box the Velop contains a router. This means that everything ‘downstream’ of it -- your WiFi and anything you wire to a Velop node -- is on a different IP subnet from everything ‘upstream’. That’s what routers do.

So when plugged into the Arris box your Arc would be on a different subnet from your WiFi devices. Sonos controllers and players all need to be on the same subnet. 

OK that makes sense now. Thanks for that explanation.