Answered

Error 1000


Hi, I wanted to add the last element to my Sonos set (SUB + 2x Era 300), - Arc. I get to the point of updating the software and I get "Error: 1000". And so on. I've already tried factory reset and moving closer to the router. It's always the same. Maybe you have some ideas or similar experiences?

icon

Best answer by catalept 7 June 2024, 10:20

View original

23 replies

Userlevel 6
Badge +11

Just an outside chance, but have you updated the app this week as there was an update. I don’t know if the software version impacts the system’s ability to update the firmware of the speakers, but ensure you’re on the latest app version.

Also try connecting the Arc to the router by Ethernet cable if it isn’t already, and try the system update again.

FIXED:
I have installed Windows App and the software update for arc went smoothly. Now I can use Arc in my system.
So the answer is the only one - poor new mobile app.

Userlevel 6
Badge +11

Glad it’s sorted.

Pardon my ignorance. What is Windows App? I’m having the same issue and would love some help 

Userlevel 6
Badge +11

Pardon my ignorance. What is Windows App? I’m having the same issue and would love some help 

It’s the Windows version of the Sonos app. For Windows desktop. 
https://support.sonos.com/en-gb/downloads

I have 2 sub mini's one for my arc and one for my amp, I'm not able to update the software of the new amp mini sub I'm trying to add. Error 1000 message. 

Yeah man. My arc and Gen 3 sub have update issues, error 1000, and continue to be issues.  Terrible. 

No help with the chat. I need to call Monday. Reloading the app does not help. No way to use the Sonos app as it defaults to a software update immediately when I open the app. It's stuck in a loop. The software update does not work given the error message 1000. Stuck. 

Can Anyone help? 

Userlevel 1
Badge

I’ve had two products with error 1000 and 30 when trying to update: one amp and one beam. Other Amp devices and other products updated no problem to 16.2. 

 

The only way I got this to work is to follow what tech support advised. It makes no sense why this allows it to work, but it did ultimately get there…

 

  1. Unplug ALL sonos devices. If you have a roam or other portable, disconnect from ac power and turn off
  2. kill the sonos app on your device 
  3. wait 5 minutes (this is important)
  4. open the sonos app, make sure no devices are found (eg you didn’t forget one)
  5. plug in ONLY the impacted device to power. Kill the sonos app. Wait another 5 minutes
  6.  Make sure any portable devices are still off and didn’t power back up somehow
  7. launch sonos app, it should say an update is ready. Approve the update and wait very patiently. 
  8. The update should work.  If not, verify no other sonos portable devices turned on during the process (this was killing me i believe) and just keep trying until it goes through.
  9. if it STILL fails, bring device to your router and plug in via Ethernet and repeat all of the above. 
  10. Hopefully that works. Repeat the above with impacted devices one by one. I certainly hope this never happens again.
     

Sonos engineering: if you are out there, you have a major issue on your hand. I’m pretty sure a lot of folks are “suffering in silence” at this point and you need to put some attention on fixing this problem.  It completely undermines confidence in your whole system and products…

have the same problem error 1000 with my sub mini, can’t update my hardware.

also, i’m stuck on ‘’software update’’ on the win apps and android apps, i can’t do nothing on it.

 

Tried to force stop, uninstall/install, clear cache,

try to connect my stuff on other wifi and push the update, try with cable nothing. 

 

 

 

Userlevel 1
Badge

@zelgoryte did you unplug everything from power? No amount of resetting on the iOS/Android/Mac/Win app seems to make any difference here,

@zelgoryte did you unplug everything from power? No amount of resetting on the iOS/Android/Mac/Win app seems to make any difference here,

 

Yes, i did that too. Tried all your steps but i stay stuck on the error 1000 and the software updates. Will try again 😅

Same for me - tried everything for a few hours and could not get the Sub to update software. Although I believe the Sub is already updated it may be an issue with the System software? I’ve tried to reload the app a few dozen times and still nothing. I am waiting for customer service. Keep you posted. Makes me want to purchase a 3rd party sub and just hard wire it to my sonos amp. 

Same issue here, error 30 and error 1000 when trying to update the Sonos Arc.

Since I can not update, I can not add again the surround speakers.

Tried everything without success

This issue is going for one week and Sonos is doing nothing. They really do not care about their clients

I was able to load the software update using my iPad. My android phone Sonos app would not allow me to update the software for my mini sub giving me the error. If you have an apple device that might work. 

Once I loaded the software then my android Sonos app worked fine. 

Same issue here (based in Japan). Have been getting error 30 (sometimes it alternates with 1000) since last weekend. Spent a total of 4 hours (no joke) on the phone with support and nothing worked. Except they had me hard reset the arc and since the update still fails as a result now I cannot even use it (since to start using it it requires the update first). 
In the end all they  could say was “our engineers are working on it, please wait”. 
So now I find myself with a full Sonos system that is pretty much furniture.

I’m on Mac by the way so one of the answers here does not apply. Will try what was suggested by Mattyv123 but I’m pretty sure it is something I have already tried in the 100s tests I have done in the past few days. 
 

After 2 hours I managed to update the products via a Windows PC

Anyone succeeded any other way than with the windows app? Just tried it and it seems for me that I still can't complete the update. 

@Andreannemathon only solution for now is to use a VPN to update depending your location 

 

Was just able to update two Moves via Windows App.  I unplugged all items, started app, powered on one device needing update and was able to complete.  Repeated same for second.  After updates, powered on all devices and all function normally.

buenos dias tengo un bean 2 y quiero conectarlo con un sub que compre hace una semana y no puedo enlazarlos a los dos
me da errer 1000 y 1002

como puedo solucionarlo , ya lo intente todo lo indicado pero no puedo

Reply