Answered

Dolby Atmos not working on LG G series TV Netflix app but does on Prime

  • 21 May 2023
  • 3 replies
  • 3216 views

  • Contributor I
  • 2 replies

Hello,

 

Similar to a lot of people I’ve been having trouble getting Dolby Atmos to work on an LG TV native app, specifically an OLED55G16LA TV.  It does work on the limited Amazon Prime content so not sure what the issue is but sounds like a software or setting issue rather than hardware. And I do have a premium ultra HD Netflix account.

 

I’ve got an Arc linked to two Era 300s and a sub gen 2.  eARC is selected in the sound menus, and I have tried either ‘auto’ or ‘passthrough’ as suggested in some of the other threads.  Dolby Atmos in the menus I believe should be greyed out as that is for when using the TV internal speakers only. The solution suggested else where of unplugging the HDMI, re-plugging and selecting eARC makes to difference.  There are two options I’ve not seen mentioned inn other models ’TV sound mode share’ or ‘sound bar mode control’ but switching these on or off doesn't make a difference.

 

At best I’ve improved the output from checking the app audio currently playing from PCM 2.0 to PCM 5.1 by playing around with the options but no Atmos spatial audio.  Any help is appreciated.

 

 

 

 

icon

Best answer by GuitarSuperstar 21 May 2023, 11:50

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

I understand that you're experiencing issues with Dolby Atmos not working on the Netflix app of your LG OLED TV, while it does work on the Amazon Prime app. Here are a few suggestions to help troubleshoot the problem:

1. Check Netflix app settings: Within the Netflix app on your LG TV, ensure that the audio settings are configured correctly. Look for any options related to audio output or audio formats and make sure that Dolby Atmos is enabled if available.

2. Verify Netflix plan and content: Ensure that you have a Netflix plan that supports Dolby Atmos and that you are trying to play content that is available in Dolby Atmos. Not all titles on Netflix support Dolby Atmos, so it's important to choose content that specifically mentions Dolby Atmos in its description.

3. Update TV firmware: Make sure that your LG TV has the latest firmware installed. Check for any available firmware updates through the TV's settings menu or by visiting LG's support website. Keeping your TV firmware up to date can address compatibility issues and improve performance.

4. Reset TV audio settings: Try resetting the audio settings on your LG TV to their default values. This can be done through the TV's settings menu. After resetting, configure the audio settings again and test Dolby Atmos playback on the Netflix app.

5. Contact LG support: If the issue persists after trying the above steps, it's recommended to contact LG customer support for further assistance. They can provide specific troubleshooting steps based on your TV model and help resolve any software or compatibility issues related to Dolby Atmos on the Netflix app.

When reaching out to LG support, provide them with detailed information about your TV model, firmware version, and the steps you've already taken to troubleshoot the issue. This will help them assist you more effectively.

Please note that some LG TV models may have specific limitations or requirements for Dolby Atmos playback, so it's best to consult the user manual or contact LG support for accurate information regarding your specific TV model.

 

Regards;

David Johnson.

Userlevel 7

Keep the Digital Sound Output setting on the TV set to Pass Through. And make sure you are playing the ORIGINAL language audio track. Also, log in to your Netflix account on a web browser and go to your profile settings. Under Playback Settings, make sure “Data usage per screen” is set to HIGH.

Thank you both.

 

@GuitarSuperstar  after thinking it can’t possibly be that as Dolby Vision was defaulting fine, after finding the menu option mentioned and turning the TV on and off a few times Dolby Atmos magically appears in the Sonos app.  Thank you so much,  I spend hours yesterday trying to sort this.  A bit cheeky of Netfix to charge you the premium fee and turn off the benefit by default…...

 

For anyone else  with the problem you have to be on a laptop browser, not the TV app or a phone, click a use icon > account > the user icon again under PROFILE & PARENTAL CONTROLS > playback setting (eighth option down) and select HIGH.