Deactivate Wifi to use only Ethernet in a home theater setup

  • 28 November 2023
  • 8 replies
  • 126 views

Badge

Hello community,

I have the following setup in my living room:

  • Beam
  • Sub Mini
  • 2 Era 100

Beam and Sub are using Ethernet. Era 100 are using Ethernet through Anker USB-C - Ethernet adapters.

They are all in the same very good local wired network.

I’ve tried to disable Wifi on all the devices who had the option (Beam & Sub Mini) but the result was very bad. The sound was very bad, intermittent.

I’ve tried to ask the support if that was normal and they told me to switch On Wifi on all devices to fix the issue, without explaining me why.

I’ve always tried to favor Ethernet over Wifi at home, for various reasons, including performance and stability.

Is there any good reason for an Ethernet-only setup not to work?

Am I alone to think that this setup should work even better on Ethernet and that we should be allowed to switch Wifi Off when all devices are connected through Ethernet?

Thanks a lot

Benjamin


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Not ‘as designed’ would be my best guess. The intention was to use that hidden 5Ghz channel to connect the surrounds and Sub to the soundbar.

That being said, it should be working normally on the fallback of wired. I’d suspect some sort of interference in your network causing these dropouts, the most likely in a wired situation being duplicate IP addresses. You may want to ensure that you’ve set up assigned IPs in your router for all your Sonos devices.

Beyond that, I don’t have any access to the hard data that would be in a diagnostic, so I’d be just furthering the guesses. 

Userlevel 7
Badge +17

Sonos advises to use the dedicated 5Ghz connection between soundbar and surrounds, as it is the fastest and most stable way to connect them. For this “wifi” on the soundbar most be turned on, while the soundbar can stay connected via cable. Have you tried this? 

Userlevel 7
Badge +22

Part of the confusion is the Sonos menu option says: “Turn off WiFi.”

What it actually does is turn off the internal radio, that is used for WiFi BUT ALSO the 5 GHz link to the Sub and Surrounds.

I was having issues here long ago and Sonos suggested removing the Ethernet from all my surrounds and Subs and it stopped the odd behavior.

Badge

Thanks all.

Stanley > That’s indeed a very bad naming in the app but that’s now clear for me. Thanks

Airgetlam > I have setup static IPs for the devices so IPs shouldn’t be an issue.

I have done more tests today.

It seems that Beam and Sub Mini are behaving well when they are connected through Ethernet. They are not using the Wifi anymore even if Wifi configuration is still available “in the Sonos app”.

But when I turn radio Off for the Beam and Sub (Wifi Off in the app), the Era 100 as surrounds seems to connect to Wifi instead of Ethernet. And I do think that the dropouts I have is because my Wifi is bad (that’s part of the reason I would prefer the devices to prioritize Ethernet when available).

I’ve tried to shut down Wifi completely at home and the Era 100 didn’t worked anymore (Beam and Sub were working), even when connected to Ethernet.

Conclusion : I’m wondering if the Eras are using Ethernet at all.

Era 100 are using Ethernet through Anker USB-C - Ethernet adapters.

Not the correct Sonos adapters then. They may work, or could well not.

Go to http://x.x.x.x:1400/status/enetports for one of the Eras and see if the Ethernet link is up. x.x.x.x is the IP obviously. 

FWIW when Ethernet is active the radio is disabled so, for example, http://x.x.x.x:1400/status/ifconfig doesn’t show the interface at all. 

Badge

When Radio is on in the Beam, this is the result I have with one of the Era :

On my router, I see the Eras connected to the same Ethernet port as my Beam. However they are not so the Beam might act as a network switch.
 

When Radio is off in the Beam, I can’t access http://192.168.1.30:1400/status/enetports anymore and this is what I see in my router. The Eras are back to the right Ethernet port they are connected to but they actually don’t work.

By the way : you can see in the router map the Play1 (not connected through Ethernet) move from Ethernet when Beam Radio is On to Wifi when Beam Radio is Off.

Is that with the Beam and Sub radios enabled or disabled? 

Also what does http://x.x.x.x:1400/status/ifconfig show? There should only be br0, eth0 and lo sections. Blank out the HWaddr and inet6 info if you post a screenshot.

My post crossed with your edit.

The first pic looks sensible. All connecting back through Eth3.

The second pic would look sensible, assuming the Eras are on a different switch into Eth4. What happens if you wire them to the same switch as the Beam?