Answered

CloudBeats app crashes when playing to Port

  • 25 January 2021
  • 6 replies
  • 184 views

I recently purchased a One SL and a Port. I use CloudBeats as my main music app to play music hosted in the cloud via Airplay. For about a month it worked fine with no issues playing to either or both speakers, but starting about a week ago the CloudBeats app started crashing whenever I connect to the Port. It works fine with the One SL, but crashes every 2-5 minutes when I play to the Port. I’ve been in contact with the CloudBeats dev and he’s been trying to help, but doesn’t have a Port to test with. He said I should check the Ports firmware, which is up to date as far as I can tell. Has anyone else experienced this issue? 

icon

Best answer by Nichkramer 4 March 2021, 02:49

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 5
Badge +16

Hi @Nichkramer

Welcome to the Sonos community. Thank you for reaching out to us and for describing the issue. We appreciate you for letting us know what you have done so far. Can you stream music on your Sonos Port using the Sonos app? To help you out with this, I'll be requesting from you in submitting a diagnostic report and include the confirmation number in your response to find out the cause. Please let us know if you have any further questions or concerns, we'll be glad to assist you.   

Thanks for the response.

I just submitted the diagnostic, conf number is 1280964741.

 

I’m not having any issues that I’m aware of streaming via the Sonos App. Spotify and my line-in are working fine. I haven’t tried other services recently, nor have I tried out with other apps (besides CloudBeats) via Airplay. I also rebooted the Port yesterday, but have not had a chance to test since the reboot. When I have some time I’ll do some further experiments and update with what I find.

 

Userlevel 5
Badge +16

Hi @Nichkramer

Thanks for your response and for updating us. Upon checking the diagnostic, I can see that your Sonos speakers software is up to date, however, they are experiencing a slow network connection.

Let me suggest refreshing the network connection and your Sonos to check if this will make any improvements.

  1. Make sure that your CloudBeats app software is up to date. 
  2. Ungroup your Sonos speakers
  3. Sequential reboot to refresh your network and all your Sonos devices connection.
    • Unplug your network devices (modem, router, any wireless access points on the network) from the power.
    • Wait for 60 full seconds before you plug it back in.
    • Once the router is back online, unplug all your Sonos devices from the power.
    • Please wait 15 seconds before you plug back them back in.
    • Force close the Sonos app from your iOS or Android device.
    • When the status light on your Sonos speakers are solid white, get back on the Sonos app and check if you're connected.
  4. Group your Sonos speakers
    • Test music playback and observe your Sonos system performance.
  5. Hardwire one of your Sonos speakers to your router (not your modem).
    • Test music playback and observe your Sonos system performance.

If the issue is not fixed after performing the steps above, I recommend contacting our phone support team with your full network setup including the make and model of each device to further look into this. 

Please let us know if you have any further questions or concerns, we’ll be glad to assist you. 

I’m not terribly sure that the Sonos phone team will be any more successful at debugging a third party piece of software. The Sonos is only a receiver in this situation, and doesn’t have any ownership of the stream until after it goes through AirPlay, and is received by the speaker. My gut reaction is the Cloudbeats folks need to look at how they have integrated with Apple’s AirPlay 2 API. 

Network connections would be a separate issue, and impact all uses of Airplay 2, not just Cloudbeats. 

Thanks for the responses...

 

I’m going to try the full reboot sequence and will post an update once I do. Of additional note, I tested streaming from the BandCamp app today via AirPlay and it worked fine, so from what I can tell so far the issue appears to be isolated to the CloudBeats app. I’ll follow up with them as well.

Following up on this… I reached out to the CloudBeats app creator again and got little response, but there was a recent update and this appears to be working now, so I’m chalking it up to an issue with that app and no Sonos as was suggested.

 

Thanks for all your help!