Answered

Can't connect Sonos Arc via Sonos S2.

  • 27 September 2020
  • 5 replies
  • 1392 views

Can’t connect Sonos arc, September 27.

I just bought a new Sonos arc, trying to connect it to my Wi-Fi (2.4grr).  I understand the previous installation instructions for Sonos arc assumed the app would know it had an Arc.

But the current app and instructions don’t to do that  so, from the Sonos app S to version on my iPhone, I sign in, but then the app (when I identify I want to set up a new system)

  • does not go to “connect speakers” but
  • instead goes hunting for Sonos components and cannot find the Sonos arc.  Even when I push in the button at the back it won’t find the Sonos arc.
icon

Best answer by tonyfromAustralia 27 September 2020, 22:01

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 6
Badge +17

Hi @tonyfromAustralia.

Welcome to the Sonos community and thanks for reaching out to us. I understand the situation where you are coming from and I would like to help out.

Please allow me to ask some questions to better understand how to proceed.

  • What is the light status of the Sonos Arc? The link would help us understand what does the light indicator on the Sonos Arc means.
  • Is the Sonos Arc your only Sonos device or do you have any other Sonos devices that are already set up?
  • Upon opening the Sonos app, What does the Sonos app Say?
  • Can we try to force close and re-open the Sonos App? What does the Sonos App say right after?

Please let us know if you still have further questions or concerns. We are always here to help.

Thanks,

Is your phone connecting to the 2.4 or 5 GHz band? Is it practical for you to temporarily connect the Arc by Ethernet?

I was trying to reconnect after changed wifi. finally decided after my faulty connections to do factory reset. This, via the support link from Sonos Arc app (not so clear when seArching on Sonos website) involved

  • disconnect power cable
  • keep the pairing button (the 8 button) pushed down while reconnecting power
  • front lights flashing white and red. Then going to flashing green
  • thwn the install routine worked

 

my suggestion - clearer messaging on regular Sonos website for “reinstalling Sonos Arc after wifi changed” (not all of us go first to the app)

(Not all of us go first to the app on phone, many like me first look at website on laptop or PC)

Userlevel 6
Badge +17

Hi @tonyfromAustralia.

Thanks for your immediate response, update, and feedback we highly appreciate it.

I’m glad that everything worked out and is now fully working. I’ll make sure to send this up to our team so they can review your feedback. I do hope you continue to enjoy and love your Sonos.

Please let us know or create a topic if you still have further questions or concerns. We are always here to help.

Thanks,