Answered

Can only play Sonos from Spotify - Sonos app not working.

  • 1 January 2021
  • 4 replies
  • 1080 views

I have had a Sonos System working quite happily for years, comprising a number of play 1 speakers, a play 3 and a beam sound bar.

recently the app has been very hit and miss about finding the devices and usually displays the message 

 

unable to connect to sonos 

 

I have tried plugging one in to Ethernet which did temporarily fix the issue but after a couple of days it was the same issue and even restarting the connected speaker didn’t restart the system. I’ve tried controlling it from multiple devices with the same issue. 

 

Yet if I use the Spotify app all the devices are visible and can be used. I’m still using the s1 software but having seen so many people saying that their system has stopped working with Spotify on S2 that doesn’t seem a good move.

 

Any ideas? 

icon

Best answer by ClausN 1 January 2021, 13:49

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 5
Badge +14

Hi @Mister Tea.

Welcome, thank you for reaching out to Sonos Community since you already tried some troubleshooting steps let me try to assist you.

Since you already isolated the issue it might have to do with wifi interference this is very common nowadays especially if theirs a lot of devices connected to a single network.

If you can connect the ethernet cable directly to the soundbar instead of the surround that would be better.

I’d also be tempted to do a network refresh, by unplugging all Sonos devices, then rebooting the router. When the router comes back up, plug back in the Sonos devices.

If all out fails can you submit a diagnostic report from your Sonos system and reply back with your confirmation number?

Let us know if it works. If you need help with any other information, please be sure to let us know.

Thanks for quick reply @Mark P, I am unable to connect the sound bar via Ethernet so I unplugged all the sonos devices and restarted the router, turning on the wired one first. 

 

I am having the same issue as before with no devices visible in the app but able to use via Spotify app, I’ve also checked the iOS on my two drives which are older than iOS 14, and my wife’s phone which is newer and running iOS 14 has the permission granted. 

 

Ive submitted a diagnostic report, the number is 89566505.

 

 

Turn off wifi assist: https://support.apple.com/en-us/HT205296

On the iphone running iOS 14 also turn off private address: https://support.apple.com/en-gb/HT211227

@ClausN thank you that has sorted the problem, it’s just frustrating as that’s quite a useful function on the phones.

at least it’s cleared that up.