Answered

Beam not automatically connecting to TV via ARC

  • 30 January 2024
  • 2 replies
  • 368 views

Userlevel 3
Badge +3

I have had an ongoing issue that has always existed with this hardware pair.  I have a Beam that simply will not automatically connect to the TV sound that it is connected to via HDMI/ARC.  I must go into the Sonos app, select the Beam, and tell it to connect to TV as source. It says I need to fix the connection. It asks if it is connected to ARC. I say yes. It looks for the ARC.  It eventually finds it, although not always on the first attempt.  This can happen any time the TV has been powered off, even when the Beam has not connected to anything else or been in a group.  I don’t know if I need to trash the Beam or the TV (a recent model Insignia brand).

Any ideas of something to try would be appreciated.  TIA. 

icon

Best answer by Airgetlam 30 January 2024, 18:00

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

There’s several things I’d try, before taking the step of trashing the TV.

First, check both the tv and the Sonos for firmware / software updates, and apply them. Make sure autoplay is turned on for the Sonos in the rooms settings. Make sure ARC is turned on in the TV’s settings. Re-seat the Sonos cable between the two devices. If none of that makes a difference, call Sonos Support directly to discuss it.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your network and Sonos system.

Some suggestions to perhaps consider…

Have you tried toggling ‘off/on’ the TV Autoplay feature in the Sonos App, under ‘Settings/System/[Beam Room Name]’?

I would also try a different HDMI cable between speaker and TV.

Also, just see if disconnecting all ‘other’ devices cabled to the TV HDMI ports makes any difference. If it does, it might be a case that one of those ‘other’ devices are stealing CEC focus, so see what happens when you disable the CEC protocol on each of those devices (one at a time).. it might help you to discover the ‘culprit’.