Beam no longer auto-selects source

  • 1 November 2021
  • 2 replies

Ever since the last update a couple weeks ago,  my beam (gen 1) no longer automatically selects my TV as its source. Prior to the update, whenever I switched input on my tv, my beam would continue to stream audio from my TV seamlessly, eg switching from freeview to nvidia shield would not affect the audio output. But now, everytime I switch input, my beam deselects TV as the source, causing the audio output to stop. I then have to open up the slow-loading app and manually select TV as the source. This happens everytime i switch input, and the only way to get back audio is through the app.


Am I doing something wrong/is there a way to fix this? Its very inconvenient 


Best answer by jgatie 1 November 2021, 19:35

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7
Badge +18

Hi @Jammalam 

Thanks for your post!

If @jgatie’s suggestion didn’t help, I recommend you unplug your TV from power for a few minutes to reboot it.

You may also want to check if the TV has any software updates available.

I hope this helps.



Settings > System > Beam Room Name and set TV Autoplay to ‘On’.