Beam Gen 2 not registered

  • 30 November 2023
  • 2 replies

Hi All,

I have just gotten a Beam gen 2, and went through the app setup process, and the app just blank not loading anything.

the product is working by it self but the app is not working with the systems etc.

When I look at my system tab in the app, it’s says my product is ‘not registered’, and then when I click on that and go through the process it says I have to factory reset the product (which I’ve obviously tried already) to no luck.


Have tried the following 

  • factory reset of Sonos product,
  • reset WiFi
  • uninstalling / updating app
  • new account / setup process for my new product
  • Live chat unfortunately wasn’t helpful


Any Help would be appreciated,



Best answer by Chrisgoffin32 1 December 2023, 00:41

View original

2 replies

There’s possibly something blocking the registration to the server.

  • Are you using an LTE mobile (sim) router?
  • Is there anything special about your network-setup - firewall, shared network etc?
  • Any security software on the mobike device, vpn, firewall etc.

Check both the Sonos system requirements and controller App requirements in these two support links:

Thankyou for the reply,

managed to get it working in the end. Was to do with my phone on 5ghz and the soundbar on 2.4ghz.. so had to go into my hub settings and I turned off 5ghz temporarily so that I could get the app to sync up.. after that I turned it back on and it’s working so far!