Background noise too low on TV show

I have a Beam generation 2. I noticed on some scenes in a tv show, you can hear the background noise much more prominently on my TV speakers via my Sonos. Almost like the Sonos dulled the background noise. 

when I say background noise, I mean a scene in an office where you can hear light office sounds like phone ringing etc. or another scene in a locker room where you can hear sneakers squeaking, but the Sonos minimizes it.  I have night mode off and speech enhancement off.  Have also tried with it on.  Any suggestions?


Best answer by Airgetlam 30 March 2022, 06:35

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Have you confirmed that your TV is sending the correct signal to Sonos? My guess is that the Sonos is receiving stereo, not Dolby Digital. 

Hi there. I have this connected via optical due to my TV not having arc. Could that be the reason? And if so, how could my 12 year old TV pick up those sounds but not the soundbar. 

No, the method of connection wouldn’t matter, it’s the type of signal being carried across that connection that would. 

While watching a movie on your TV, open the Sonos controller, and go to settings, system, and about my system. Scroll down to the section labeled Sonos System Info. In the area under that dedicated to your Beam Gen 2, what does the line say for Audio In:?

It would be helpful to know which version of the Sonos OS you’re  using, the WM:x line which is also under that info for the Beam, the type of router you have, and the make and model of your TV set. 

Given that old of a TV, it wouldn’t be unusual to have an output that either doesn’t support Dolby Digital as an output, while dealing with it internally, or more likely just requiring some changes to the audio settings on the TV set to allow the Dolby Digital signal to be sent out. On an optical port, it’s not an automatic thing. 

Thanks Bruce. Stereo PCM 2.0 is listed next to Audio in. 

Sonos OS: S2

WM: 1

Samsung LN52A650

Router: Motorola 

The PCM (stereo) is what your TV is sending to the Sonos, which is why things seem slightly muddled. 

Take a look at the audio settings for your TV, and make sure that the optical output is sending Dolby Digital 5.1 to the Sonos. Worth double checking that if you’re watching a source being sent to the TV set, it also needs to be set to Dolby Digital.

Optical is a one way transmission, there’s no way for the Sonos to feed back to the TV set what it can process, as there is in HDMI ARC, so you have to set up both the source and the TV to pass through a Dolby Digital signal. 

Thanks for your help. I watch on Apple TV mostly, so I’ve changed that to Dolby vs stereo and the App confirms a Dolby output. Not sure I notice too much of a difference but maybe because I’m having to use optical output.

would I get better sound if I airplay from my Apple TV instead of optical wire connect?  I know wired is more reliable.  Also, if I’m airplaying a Dolby Atmos song to the Beam, would it come through as Atmos?

Thanks so much for your help!

I would agree, optical would be better than AirPlay 2. 

However, optical does not have the ability to carry an Atmos signal, nor can AirPlay 2. You’ll need to upgrade your TV to one with eARC before you’ll be able to use that codec. 

Thanks. So is the only way to get Atmos in Apple Music through the Sonos is via listening to music on the TV via the Sonos?

or if you use Alexa would that play the songs in Atmos that are Atmos enabled?

Right now, the only way to get Atmos in a Sonos system is through an HDMI eARC connection to a TV set, with the signal being pushed from the TV set to the Sonos. 

Userlevel 7
Badge +17

Not an Apple TV user, but can an the Apple TV not be set to output a compressed signal that contains Atmos? That could be transported via ARC (no eARC needed)?