Apple Music app on Apple TV 4K with Sonos Arc/2 One/Sub setup

  • 29 November 2022
  • 6 replies
  • 185 views

I discovered that the sound is way better this way than when playing music through Sonos or Apple Music app on my iPhone. But I’m having an issue. After a while  some albums stop playing through Sonos Ones and play through Arc/Sub only. In other words surround sound is being dropped for some reason. After restarting Apple Music app everything is back to normal, but the issue is back after listening to a couple of albums.
I’m having Atmos enabled. All devices have the latest firmware updates.

Any ideas what the issue might be?


6 replies

Without hard data, it’s just a guess, but it sounds like your surround speakers are losing connection, due to some sort of wifi interference , to the Arc. They normally connect to the Arc on a 5Ghz channel.
 

One thing I’d probably try is first, is a simple wifi refresh, by powering off (unplugging) all Sonos devices from power, then rebooting your router. I’d give the router a couple of minutes to reload its software before plugging the Sonos devices back in to power, and give those Sonos devices a couple of extra minutes to reboot and reconnect before testing again. But if that doesn’t work, I would likely submit a system diagnostic within 10 minutes of losing those rear surround speaker, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

 

Userlevel 7

When the audio drops from the Ones, are you still listening to music in Dolby Atmos or are you listening to music in Stereo PCM?

Without hard data, it’s just a guess, but it sounds like your surround speakers are losing connection, due to some sort of wifi interference , to the Arc. They normally connect to the Arc on a 5Ghz channel.
 

One thing I’d probably try is first, is a simple wifi refresh, by powering off (unplugging) all Sonos devices from power, then rebooting your router. I’d give the router a couple of minutes to reload its software before plugging the Sonos devices back in to power, and give those Sonos devices a couple of extra minutes to reboot and reconnect before testing again. But if that doesn’t work, I would likely submit a system diagnostic within 10 minutes of losing those rear surround speaker, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

 

The thing is that the surrounds do not turn completely off, just for certain albums, or better say songs! I just discovered that those songs which continue playing in surround are those marked as ‘Dolby Audio’ or ‘Dolby Atmos’! But if I restart the app songs with ‘Lossless’ only also play on surrounds again until I play a ‘Dolby’ song - after that ‘Lossless’ songs drop the surround sound 😞 So it actually seems to be an Apple TV issue rather than Wi-Fi…

It would certainly depend on what type of signal the Apple TV is sending the TV set, which passes it on to the Sonos. In cases where the signal is 5.1 of some type, then you’d have activity in the surrounds, when it is stereo, much less so. Sonos isn’t really ‘aware’ of what you’re playing, only which input it is coming through, and if it’s through the digital input, usually associated with a TV set, it will ignore the ‘ambient/full’ settings it uses for streamed music through Sonos itself.

But submitting that diagnostic might help, assuming you then call in with its number.

Userlevel 7

The thing is that the surrounds do not turn completely off, just for certain albums, or better say songs! I just discovered that those songs which continue playing in surround are those marked as ‘Dolby Audio’ or ‘Dolby Atmos’! But if I restart the app songs with ‘Lossless’ only also play on surrounds again until I play a ‘Dolby’ song - after that ‘Lossless’ songs drop the surround sound 😞 So it actually seems to be an Apple TV issue rather than Wi-Fi…

When playing music from Apple Music, look for the audio format displayed on the Now Playing screen in the Sonos app.

When playing music that is in Dolby Atmos or Dolby Audio, the Sonos app will display the Dolby Atmos logo or “Multichannel PCM” or possibly even “Dolby Digital Plus”. These are basically 5.1 audio formats so you will clearly hear audio playing out of the surround speakers.

When playing Lossless music, the Sonos app will display “Stereo PCM” because Lossless on Apple Music is just 2.0 stereo. The Arc will perform an audio up-mix of the stereo signal to create a simulated surround sound. This means you’ll still hear most audio out of the Arc, but the surrounds will play what is determined to be ambient audio.

If you want the surround speakers to be louder when playing Lossless music on the Apple TV, you can adjust the TV Level setting under the Surround Audio settings in the Sonos app.

When playing music from Apple Music, look for the audio format displayed on the Now Playing screen in the Sonos app.

When playing music that is in Dolby Atmos or Dolby Audio, the Sonos app will display the Dolby Atmos logo or “Multichannel PCM” or possibly even “Dolby Digital Plus”. These are basically 5.1 audio formats so you will clearly hear audio playing out of the surround speakers.

When playing Lossless music, the Sonos app will display “Stereo PCM” because Lossless on Apple Music is just 2.0 stereo. The Arc will perform an audio up-mix of the stereo signal to create a simulated surround sound. This means you’ll still hear most audio out of the Arc, but the surrounds will play what is determined to be ambient audio.

If you want the surround speakers to be louder when playing Lossless music on the Apple TV, you can adjust the TV Level setting under the Surround Audio settings in the Sonos app.

I understand what you mean and I know about TV level setting. The problem is that the surrounds sound just fine when I play regular stereo songs, but as soon as I have played a Dolby song they become completely quiet for all further Stereo songs. Only restarting the app helps until another Dolby song has been played. 
This happens exclusively when I use Apple Music app on Apple TV. 

Reply