Answered

TV Picture Problems

  • 28 January 2021
  • 4 replies
  • 73 views

Hello -

I’m having some problems with the picture on my TV and my Sonos ARC (Plus two SL’s in back of the room). First of all, here is my set up. 

TV: Visio V Series (purchased in December 2019). My TV connects wirelessly to the internet, as does my Apple TV and my Nintendo Switch).

I have 3 HDMI inputs in my TV, which are summarized as follows:

HDMI 1 (ARC): My Sonos ARC Soundbar

HDMI 2: My Cable box (Xfinity, if that matters)

HDMI 3: I have an HDMI Switch plugged into this, which includes a Blu Ray Player, Nintendo Switch, and my 4K Apple TV

 

The problem is that when I am watching cable or watching anything on my Apple TV, the screen goes black for a moment (anywhere from 2-4 seconds) before it resumes play. Sometimes, it will be hours before this happens, and other times, this will occur 3-4 times per hour. I *sometimes* will get a message after one of these blackouts that my TV has “found” the audio system (but not all the time). The unusual thing is that this NEVER happens when I am playing my Nintendo Switch (which uses a wireless connection so I can play online), and I do not experience any type of issues when I am just LISTENING to music via my Sonos App.  I ONLY have issues when I am watching Cable or something on my Apple TV. 

I think it’s also worth mentioning that PRIOR to having Sonos, I never had any type of picture or audio issues with my cable or Apple TV.  

Does anybody have any ideas on how I can fix this?  I LOVE my Sonos system and the way it sounds except for this particular issue.  Maybe I need new HDMI chords? 

Thank you so much!

icon

Best answer by Corry P 10 March 2021, 16:08

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7
Badge +22

While it could be a cable problem, it is more likely to be a bug in the TV. Check with Visio to see if there are any firmware updates available.

Userlevel 7

Try testing a different HDMI cable. I would also try removing the HDMI switch and just connecting the Apple TV and cable box directly to your TV to rule out any interference the HDMI switch might be causing.

I am also having this issue. Panasonic Viera TV and Sonos arc. When I’m watching Amazon or Netflix apps on the TV all seems to be fine, but when I’m watching Sky through the satellite feed and via the HDMI 1 input this issue persists. It’s almost like the TV momentarily tries to switch to another input automatically, but then doesn’t.

If I’m watching apps through the sky box it is even worse, it cuts back to the Sky Home Screen!

If I disconnect the Sonos Arc there are no problems.

I have another identical Panasonic Viera and tried switching them over, but the same problem.

Userlevel 7
Badge +18

Hi @WillDenver 

Welcome to the Sonos Community!

It sounds like you’ve got a CEC conflict on your system, and it sounds like that conflict is making the TV refresh what’s connected and it pops up a message about the Audio system (as that’s something the TV feels is worth mentioning) - the other devices will be getting refreshed too, but you don’t get messages about those. This conflict could be caused by one of the source devices you have connected, the HDMI switch itself, or the TV finding itself with more connections than it ever expected (with it’s 3 HDMI ports).

First, I recommend unplugging the TV from power for a minute. This can fix quite a few problems as it refreshes the TV’s software in a way that Standby just doesn’t do.

Next, you’ll need to try and identify the problem device. Disconnect them, one at a time, until the issue stops. Whatever you last disconnected may be the source of the issue. Connect the others again (one at a time) and test again. As I mentioned, it may be the number of devices, rather than a particular device.

If you think you’ve found the culprit, look at it’s settings and disable CEC - if you can’t, you may want to search Amazon for “cec less adaptor” for a small device that just removes the connection on the HDMI cable that carries CEC signals.

If it’s the number of devices, this should also be able to be fixed by disabling CEC on some.

It’s also probably worth searching the internet for your HDMI switch’s name and “CEC problems” - if there are a lot of reports of similar issues to yours, you might want to replace it.

I hope this helps, or at least puts you on the right path.