Terrible audio quality playing music through TV

  • 25 April 2023
  • 4 replies

I have an LG UK6090PUA TV connected to a Gen 2 Beam, along with a Gen 3 Sub and two One SLs for surrounds. The setup sounds great for movies and TV and also for music played through the Sonos app. Music played through the TV, however, sounds downright awful. Like really, really bad — totally unlistenable, which is a real shame because I have a great music video collection that I would love to have playing in the background when hosting company.

I’ve downloaded a bunch of open-license music videos from the internet and extracted the audio for listening only, and I’ve got both the MOV video and MP3 audio versions in my media library. It’s the same exact audio stream for both the videos and the audio files (16-bit 44.1kHz stereo), and having the same audio stream in both formats provides a clear example of just how stark the contrast is.

A song played through the Sonos app on my phone sounds great, with all speakers playing at appropriate volume levels and the stereo signal split appropriately between left and right speakers. The same exact song played as a video on the TV sounds like garbage, with Sonos apparently trying to play the stereo signal in some kind of pseudo-surround mode. Sound from the Beam is muffled and the One SLs hardly make any sound at all. When grouping with other Sonos speakers in other rooms, they all have the same issue, creating an unpleasant soundscape that permeates the whole house. Definitely not suitable for parties!

Note that I have tried all the recommended tricks in the Sonos app, like disabling surround mode and all that. The Beam just seems hellbent on processing the HDMI signal from the TV in an overly complicated way instead of just handling 2-channel audio as 2-channel audio. I don’t watch much TV, but my wife says that some of her shows sound “off” with this system — which makes me wonder if all those shows happen to be broadcast in stereo.

Prior to splurging for this Sonos setup, I was using a JBL Bar 5.1 with this TV, and prior to that a cheap Visio soundbar/sub combo. Both worked much, much better with this TV for playing videos with 2-channel audio than my Sonos system, which is both frustrating and weird.

I don’t know if this is a problem with the TV, the Sonos, or both. Or perhaps the HDMI cable? Or the way the videos are encoded?

Has anyone found a way to fix this problem? Is anyone out there NOT having this problem?


Best answer by Jamie A 26 April 2023, 14:48

View original

4 replies

Userlevel 7
Badge +14

Hi @dayofthedave, welcome to the Sonos Community!

When Sonos is provided stereo audio from a TV and you have surround speakers bonded, it will attempt to up-mix it to provide information to the full Home Theater setup. This is likely why the audio sounds different and not as you expected.

An option might be to extract the audio streams from your .mov files so you can deliver them to Sonos without involving the TV, but as video files are not generally compressed with high audio quality in mind, I believe you would get better results by simply downloading said tracks as audio files initially.

Disabling surrounds in the Beam's settings should prevent the up-mixing, but as you have already attempted this with no luck, it’s possible that the device that it providing Sonos with the file is up-mixing the file before being sent through to Sonos, whether the file is presented to Sonos from your TV, AppleTV, a device stream, etc.

However, I think a feature request to have a toggle or option in the Sonos app to prevent Home Theater setups from up-mixing stereo TV audio would be a great idea. I would suggest making a separate thread regarding this and for other users to respond. I could mark the new thread as a feature request and send it along to our team for further consideration.

I hope this helps!

Thank you!

Do you have any suggestions for how I might go about testing the signal being received by the Beam, to see if it’s the TV that is up-mixing the signal? And if that is the case, is your feature request idea suggesting that there might be a way for the Beam to somehow prevent the TV from doing that? Perhaps a config setting in the app that causes the Beam to show up as a stereo device?

As an alternative, how about a config setting that tells Sonos to simply down-mix all signals to stereo?

Userlevel 7
Badge +14

Hi @dayofthedave,

If you check the Now Player screen or checking About My System on the Sonos App when the Beam is receiving audio from the TV, it should tell you what signal format it’s playing in.

I’m not exactly sure myself if it is possible to stop the up-mixing from happening, but a feature request thread is something we can forward to our development teams for their consideration.

Unfortunately I wont be able to comment on the future roadmap of such a feature, but again, I’d be happy to mark this as a feature request.


Checking the Now Playing screen on my phone indicated that the Plex app on my TV was converting the stereo signal into Dolby Digital 2.0, and the Plex app on the Amazon Fire TV stick plugged into the TV was converting the signal into Dolby Digital Plus 5.1. In both cases, the resulting sound was bad, pulling various bits away from the Beam and sending them to the surrounds with lots of artifacts.

I figured out how to make it work on the Fire TV stick:

Settings > Display & Sounds > Audio > Surround Sound — change to “PCM”

Thanks for the help!