Surround Sound with Connect:Amp no longer working

  • 5 October 2017
  • 44 replies
  • 3861 views

I currently have a SONOS Playbar hooked up to my tv and have two built in ceiling speakers that are connected to my SONOS Connect:Amp which is hardwired into my router. I recently noticed that the two ceiling speakers stop playing sounds or music when ever a movie was playing or I had music playing on the Playbar. I tried doing a retune and it always said speakers were missing. I just updated all speakers and app to try and fix the problem. Nothing worked, so I decided to factory reset my Connect:Amp and reset it up as it's own device. Once I did that, I could play music through the speakers so I knew they were still working. I then went to the website: http://######:1400/wiredsat.htm and replaced the # with my Playbars IP code to set up the surround sound. I then selected the Conncet:Amp to set up as my Left and Right surround sound speakers and set their distance away from the tv. Hit complete and was notified that I was all set up. I then went back to the app and retuned the speakers for the new surround sound, and was notifed that "speakers where missing" yet again. I've redone this 3 times with the same result. any advice would be greatly appreciated.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

44 replies

I'm seeing the exact same issue. Noticed the rear speakers (connected to the Amp Connect) stopped working when I downloaded the latest software.
Same here. Playbar sound will no longer play through other rooms/speakers.
Could I convince you all to submit a system diagnostic, and post the number here, for the folks at Sonos to look at? If there's a bug, the data you submit might help them track it down.
System diagnostic submitted. number is: 7920792.
thx.
Userlevel 5
Badge +3
System diagnostic submitted. number is: 7920792.
thx.


Thanks for submitting the diagnostic, jcurtis200, as it's allowed me to diagnose the root cause of the problem. When pulling the readings I can see there is a gateway mismatch as there appear to be two DHCP servers onsite. We'll want to start by getting the topology for the home network. Can you let us know the make and model of the router at your location? Do you have the CONNECT:AMP used as surrounds wired to the main router or another device like a network switch (possibly managed)?
Andy, i'll double check but not aware of a second DHCP server on the network. I have a comcast modem set to bridge mode connected to a Luxul router (model is the XBR-4500) set to 192.168.0,.1. That's where the DHCP server is running. The router is connected to to a managed switch (I double checked to make sure DHCP is not running on the switch) address 192.168.0.3. The sound bar and amp connect products are both plugged into this switch. All address fall into the 192.168.xxx range. Is there a alternative range your seeing? thx
Userlevel 5
Badge +3
I'm not seeing an alternative range, but when I pull the diagnostic I see the following three players are reporting 192.168.0.11 as the gateway and not 192.168.0.1: Family Room (Right PLAY:5), Fam Rm TV (SUB) , and Fam Rm TV (CONNECT:AMP).
Thanks Andy, I'll do some checking to see why the gateway is listed as .11 rather than .1 Big help. Thanks!
System diagnostic number: 7923765
Andy, looks like a video matrix product had a DHCP server running - even though the interface showed it disabled. I've pulled that device off the network. Did a hard reset of the Sound Bar and Amp Connect running the rear speakers. All devices should be getting IP addresses from MAC A4134E3E39A6 (Luxul Router). Reset up the 5.1 as before but still not getting sound out of the rear speakers. Did check the Amp Connect was working before adding it back into the 5.1 surround. Ran a new Diagnostic: 7930447. As I mentioned, it was working before I downloaded the new app. Not sure it that's related. Thanks again
Andy - solved the problem. On reboot of the speakers they came up with wifi enabled. I did the IP command to make the wifi off (persistent) and everything is working now. thx for your help
Userlevel 5
Badge +3
Andy - solved the problem. On reboot of the speakers they came up with wifi enabled. I did the IP command to make the wifi off (persistent) and everything is working now. thx for your help

Thanks for the followup, jcurtis200. I know I'm a tad late getting back to you, but I'm glad I was able to help.
Andy - solved the problem. On reboot of the speakers they came up with wifi enabled. I did the IP command to make the wifi off (persistent) and everything is working now. thx for your help

Care to share how to send this "IP command" you speak of?
Hi - I am having the same problem. As with tjbarter, I have ceiling speakers used as surround speakers (via a connect:amp) connected to my playbar as +L and +R, and recently noticed they are not working. I can unpair the ceiling speakers from the playbar (and they become a room in their own right) and they work fine. However, when I re-pair them with the playbar (using the http://######:1400/wiredsat.htm website) they do not play any sound. When I try and finetune them I get the "speakers are missing" notification. I have repeated this several times.

From the comments above it seems there might be some kind of IP address issue - although this is getting beyond my technical limits. I have run a diagnostic - 7993544 - if Andy B or colleague can assist!
Userlevel 1
Badge +1
Same problem except I don't get any errors, music just doesn't play through the surrounds. When I separate the amp, music plays just fine. All components are wired via ethernet to the same router through a dumb switch. I submitted a system diagnostic
Beyond just submitting the diagnostic, you need to either post the number here, or call in and give them the number. I suspect without knowing precisely which one goes with what symptom, they might have a hard time figuring out what they're looking for. I suspect that they get thousands a day, and looking at each one trying to figure out what the issue is might be daunting.
Just tried going through the whole setup again with the same end result. Surround sound speakers still not being recognized. Submitted a new diagnostic, code: 8044625. This is getting frustrating, so thank you in advanced for any help.
There's definitely a DHCP or Gateway issue with this, it's as if the Connect:AMP acts as its own DHCP server and screws everything up.

I've just bought a Connect:AMP to use some old speakers as rear surrounds... wired my PlayBar and the Connect: into my router, rebooted it, and all of a sudden I couldn't even connect to my router at all! It kept saying 'wrong password'. Anyway I unplugged the Connect:, rebooted the router again, and then all was well (though no surrounds obviously). It worked fine adding the Connect: wirelessly to the SonosNet network created by my PlayBar, but obviously it then doesn't work as surround speakers, just as a random extra stereo pair. And you can't use the trick here https://bsteiner.info/articles/disabling-sonos-wifi to shut off the WiFi as it won't permit it unless the Connect is connected via a cable.

Anyway what did work is wiring the Connect: into the Router, but then wiring the PlayBar into the Connect (ie NOT into the router) so that there's then only one Sonos device plugged directly into the router. All works totally fine now, and I have surround working!

There must be something to do with each Sonos device trying to create its own separate SonosNet subnet when you wire them separately into the router, though why that then breaks the whole router setup is beyond me.

Hope this helps!
PezzaUK You had a network broadcast storm, basically all the network traffic keeps being passed on and floods the network. Its was broken by having just one Sonos device wired but luckily you worked out the fix.
Hi, this seems to be an old thread, but I have the same issue. I have a Playbar, SUB and 2 ceiling speakers connected to a Connect:AMP. They are connected over WiFi, and share the IPs 192.168.86.*, from the DHCP served by Google WiFi routers. I've performed the "wiredsat" step and they all show up correctly in the Room Setting, +SUB +LS +RS. If I decouple the surrounds, music plays normally, but when working in surround mode, I don't seem to get anything. My diagnose # is 1958721631. Can you please provide some guidance?
Hey same issue of no rears when in connected mode. Ran the diagnostic under 312106430. I have a Apple time capsule router and trendnet gigabit switches. Help!
Are both your PLAYBAR / PLAYBASE and the CONNECT:AMP wired to the same router?
Play bar and amp connected to the same router
Well, then, I suspect that diagnostic will need to be looked at. It was only a potential that needed to be addressed, since you indicated 2 separate devices.
Userlevel 7
Badge +20
Hey same issue of no rears when in connected mode. Ran the diagnostic under 312106430. I have a Apple time capsule router and trendnet gigabit switches. Help!

Hi elsn0008,

Your PLAYBAR is showing a stereo signal coming from the optical cable. Can you check your TV's audio output settings to make sure it's sending out a surround signal?