Answered

Surround sound (Sonos Arc + Sub + 2 Ones) echo's at times

  • 11 June 2022
  • 8 replies
  • 202 views

Userlevel 3
Badge +5

We have been using the Arc in surround setup for quite a long while, but recently we have been experiencing problems that it echo’s at times. It is very sporadic. But the two back speakers (Ones) are slightly out of sync. It always happens when watching TV, but today for the first time also happened playing music.

The solution for it is to basically to turn the arc off and on (i.e. pull the power and reconnect it). Then it all works perfectly again… sometimes for a few weeks, sometimes for a few days.

The Arc itself is connected wired and the two Ones and the Sub are connected through Wifi. We have a Boost.

Anyone have any experience with this and perhaps know a solution? I’ve not changes any settings. I’ve played with the lip sych setting when it happens, but that seems unrelated.

icon

Best answer by Asgorath 22 June 2022, 08:18

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

My suggestion is to log these events by posting a diagnostic here immediately after you encounter one of these events and again after the reboot. You can also take this up with SONOS support. They will  need the diagnostic reports too. Offhand, I don’t know if rebooting the other units will help in the long term. Refrain from Factory Reset without further consult.

Userlevel 7
Badge +21

Add static/reserved IP addresses for all your Sonos to your router’s DHCP pages. Power down all Sonos, reboot router, power up Sonos one at a time.

Not promising that will work but I did it here, long ago and for other reasons, and haven’t seen the echo issues here. Only takes a couple minutes to do.

Userlevel 3
Badge +5

Add static/reserved IP addresses for all your Sonos to your router’s DHCP pages. Power down all Sonos, reboot router, power up Sonos one at a time.

Not promising that will work but I did it here, long ago and for other reasons, and haven’t seen the echo issues here. Only takes a couple minutes to do.

 

Like most devices they have static ip addresses. I have not tried rebooting all devices however. Going to try that. Also saw the last update had not installed. Perhaps that addresses the issue. Thnx!

 

Add static/reserved IP addresses for all your Sonos to your router’s DHCP pages. Power down all Sonos, reboot router, power up Sonos one at a time.

Not promising that will work but I did it here, long ago and for other reasons, and haven’t seen the echo issues here. Only takes a couple minutes to do.

 

Like most devices they have static ip addresses. I have not tried rebooting all devices however. Going to try that. Also saw the last update had not installed. Perhaps that addresses the issue. Thnx!

 

FYI, the vast majorty of routers use DHCP service to control IP address handling by default and is not static. You can force your router to use a “static” IP address for each device by linking the IP to the the unique device MAC address but this will need setup for each device. 

Often an IP can ‘appear’ to be static as the router will lease out the address for a period of time, sometimes months.  

I would also add to Stanleys post the following, firstly, 2.4Ghz is a very crowed place, make sure you dont have any cordless phones, cameras or ZIGBEE devices between your router and your equipment.

Secondly, check which channel your router is using. if its not 1, 6 or 11 change it to one of them. and as far away from wherever it is now. ie, if your using channel 10, move it to 1. Your router should tell you this.  

If you live in a crowded area with a lot of people, your best to be on the same channel as a neighbour rather than near it. ie, if your neighbour is unhelpfully on channel 2 and you want to use 1, firstly check if 6 and 11 are reasonably free and if not, use 2 (or better yet get them to move to 1!) 

 

2.4Ghz is a mess just now and absolutely can cause all sorts of issues.

Userlevel 3
Badge +5

 

FYI, the vast majorty of routers use DHCP service to control IP address handling by default and is not static. You can force your router to use a “static” IP address for each device by linking the IP to the the unique device MAC address but this will need setup for each device. 

Often an IP can ‘appear’ to be static as the router will lease out the address for a period of time, sometimes months.  

I would also add to Stanleys post the following, firstly, 2.4Ghz is a very crowed place, make sure you dont have any cordless phones, cameras or ZIGBEE devices between your router and your equipment.

Secondly, check which channel your router is using. if its not 1, 6 or 11 change it to one of them. and as far away from wherever it is now. ie, if your using channel 10, move it to 1. Your router should tell you this.  

If you live in a crowded area with a lot of people, your best to be on the same channel as a neighbour rather than near it. ie, if your neighbour is unhelpfully on channel 2 and you want to use 1, firstly check if 6 and 11 are reasonably free and if not, use 2 (or better yet get them to move to 1!) 

 

2.4Ghz is a mess just now and absolutely can cause all sorts of issues.

Thanks…

I know, I am very familiar with router settings and networks. It’s all balanced out with channels used by others and the ones I use myself (both Wifi and Zigbee - using the diagram of https://www.metageek.com/training/resources/zigbee-wifi-coexistence/). They are setup to not overlap. At least where I have control (i.e. cannot ask the neighbors. But working around theirs). So Wifi is 1, Sonos is 6 and my two zigbee networks fitting inbetween. Avoiding the 11 as it’s crowded as … 6 also is bit more busy, but my main Wifi gets preference. Incl. tweaking my router in terms of basically.. everything. I’ve not had any problems with this setup until a week before posting this topic.

I have noticed in the past before tweaking this that Sonos is quite ‘touchy feely’ and quickly upset for network issues. But this would be unworkable if this is the case. it cannot be more optimal. Only thing I can still do is also wire both Ones. I really wish Sonos would switch to the 5Ghz network (Sonos devices act as Meshnodes?)

 

What I honestly would like to do is remove my boost and get on the Wifi of my routers. its a very solid Meshnode network with a router/node at every floor. But not sure that can be done?

 

Userlevel 3
Badge +5

I’ve removed the Boost and also disconnected any Sonos device from being wired. Causing all my Sonos devices to connect to different meshnodes of my own Wifi network and the ‘SonosNet’ to be disabled (seems if any device is connected wired it’s enabled and that device becomes the primary router instead of the boost).

So far results have been good. It seems the SonosNet was/is the problem. Bit ironic that wiring a device causes worse performance, but oh well :)

I’ve removed the Boost and also disconnected any Sonos device from being wired. Causing all my Sonos devices to connect to different meshnodes of my own Wifi network and the ‘SonosNet’ to be disabled (seems if any device is connected wired it’s enabled and that device becomes the primary router instead of the boost).

No Sonos device, whether a Boost or a speaker, acts as a router.  The Boost is a networking device that bridges the SonosNet and WiFi segments of your LAN

So far results have been good. It seems the SonosNet was/is the problem. Bit ironic that wiring a device causes worse performance, but oh well :)

I think you should reserve judgement on this.  To which device did you wire the Boost?  Does your  network still contain an ISP router?  Which device is acting as DHCP server?

I hope your Sonos system continues to be stable in WiFi mode, but if you have further issues please come back for further advice.

Badge

Install the new firmware 14.10 and the issue is solved....