Answered

Sub and Surrounds stopped working after updating to S2

  • 5 August 2020
  • 7 replies
  • 155 views

Userlevel 2

I have been running my system on S1 seeing as I had a bridge and Play5 not comparable. I have a number of devices so took the advantage of upgrading those products (still waiting for the Play5) but have removed the old Play5 from the network. I installed the new Boost and then updated the system to use S2.

All working except, my playbar/sub/s1-surrounds group. I have them connected for use with the TV (Home Theater) as well as being able to use them for music from the Sonos app. They worked fine with S1, but all I can get to work with S2 is the Playbar.

When I select the room, I can see the 4 units in the group and can see controls for EQ-Sub and Surrounds but changing any of the setting for Sub or surrounds does nothing. I have removed the Sub and the Surrounds from the group and then set then up again but still the same issue, they don't work. If I remove the Playbar I can then get the Sub and the Surrounds to work.

Can anyone suggest what I need to do to get these working together again.

 

Regards

Ian

icon

Best answer by iantull 6 August 2020, 13:05

Thanks for the reply and the Welcome,

After further investigation, I found the problem and the solution and contracted your support department today to let them know. 

Just to clarify, my problem also exists if using these devices with either the TV or for Music.

My Playbar has always been connected to the network via the network cable and not via Wifi and when using it and the Sub and Surrounds with S1 it worked. When I updated to S2, I found that I could from the surrounds, turn the volume up or down or pause, so the control functions worked but no sound from them or the Sub.

Solution.

I turned on Wifi on the Playbar (and remember my Playbar is connected via cable) and after doing that I was then able to get both the Sub and the Surrounds to work. 

On talking to your support department today, I also did “submit a diagnostic”

They were not sure why this has happened but it is something Sonos can look into.

 

Regards

Ian

View original

7 replies

Userlevel 4
Badge +13

Hi @iantull.

Thanks for reaching out and welcome to the community!

 appreciate your detailed post outlining your concern, let me help and get this figured out.

First off, kindly submit a diagnostic report through the Sonos app, and reply with the confirmation number. It can help identify what is causing your issue.

 

I’m looking forward to assisting you further from here.

If you have any other questions or run into any issues,  please do not hesitate to reach out.

Userlevel 2

Thanks for the reply and the Welcome,

After further investigation, I found the problem and the solution and contracted your support department today to let them know. 

Just to clarify, my problem also exists if using these devices with either the TV or for Music.

My Playbar has always been connected to the network via the network cable and not via Wifi and when using it and the Sub and Surrounds with S1 it worked. When I updated to S2, I found that I could from the surrounds, turn the volume up or down or pause, so the control functions worked but no sound from them or the Sub.

Solution.

I turned on Wifi on the Playbar (and remember my Playbar is connected via cable) and after doing that I was then able to get both the Sub and the Surrounds to work. 

On talking to your support department today, I also did “submit a diagnostic”

They were not sure why this has happened but it is something Sonos can look into.

 

Regards

Ian

Userlevel 6
Badge +15

As I understand it you should not have had surround with wifi off under S1....

Userlevel 4
Badge +13

Hi @iantull.

Thanks for the response and for your update.

I agree with @106rallyeif the Playbar is connected to the router via ethernet cable, the Wifi should be enabled for the Sub and surrounds to work both in S1 and S2.

It’s good to know that the issue has been addressed.

Let us know if you have any other questions or concerns, we are always here to help.

I had the exact same problem. My playbar is connected to optical out and Wi-Fi disabled on playbar. sub stop working After updating to S2. Then plugged in Ethernet direct connection from sub to the router/switch. With an direct ethernet cable connection plugged to Sub, the Sub started working again. After I turned on Wi-Fi on the playbar then the subs started pushing Sound out again.  Looks like the sub is a slave to the playbar which is a problem in my opinion.  I’d like the option to have WiFi disabled on playbar and my sub still running over WiFi due to the placement to the sub in my space. 

Userlevel 6
Badge +15

Sonos needs a direct connection between the Sub and the soundbar. Running it through your wifi would probably create lag,

The fundamental design of Sonos HT is for the Sub and surrounds to connect wirelessly as ‘slaves’ to the home theatre device (e.g. Arc).  This wireless connection uses the 5GHz radios in the devices and Sonos’ own wireless protocols.  It is not using your WiFi.

The real problem, and many of us have said this repeatedly on here, is the TOTALLY MISLEADING terminology used by Sonos in the setting ‘Enable / Disable Wifi’.  It is understandable that some users wrongly think they should set this to ‘disable’ when they have the HT device connected by Ethernet.  But it does not disable WiFi (the wireless connection from your router) at all.  It disables the wireless radio on the device, making it impossible for that device to communicate wirelessly to other Sonos components.

So what it actually does is disable SonosNet, not WiFi.

When will Sonos do something about this?  It causes no end of unnecessary confusion, frustration and wasted time.

Rant over.

Reply