Sourround not working

  • 27 October 2018
  • 15 replies
  • 876 views

Just set up beam sub and two ones for sourround. No sound from the sourrounds... how do i fix this?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

15 replies

Make sure the Sonos is receiving a Dolby Digital signal. You can look in the controller app, under settings>about my Sonos system to see what the Sonos is receiving. Most likely you need to adjust the audio settings on your TV, or the device feeding the TV. Or pick a show that’s in Dolby Digital...in my area, many shows are not broadcast in Dolby Digital. I usually choose a movie channel when doing these modifications.
Krylonicon,

To test speakers are okay for music audio, maybe also try changing the surrounds from 'Ambient' to 'Full' in the Beams Room Settings/Advanced Audio/Surround Settings. That provides full audio to the rear for music only.

For TV 5.0 or 5.1 audio, as mentioned by Airgetlam, I tend to use the streaming video services, like Netflix, or Amazon Video. You can even try the trailers on some movies, if you don’t wish to subscribe, just to test the surround sound.
Airgetlam. Thanks for the reply.. my sonos is recieving dd 5.1. Tv is set to dolby digital as well. Some channels work with surround and some dont. Watching football right now and it says it is sending dd 5.1 but no surround. Quite frustrating.
Thanks ken. I bought a new smart tv to go along with sonos. Netflix is on the tv and no surround when watching netflix too.. i can't figure it out.. everything seems to be in order but surround is only working on a few channels.
Krylonicon,

Note that the 'About my Sonos System' screen needs to be closed and reopened to refresh the display that you are seeing ... so if you are looking at the audio output setting in the list associated to the Beam and you change the TV output, you need to close and reopen the screen for it to reflect the updated audio output... hope that makes sense.

If you want more output to the rear TV surrounds during a stereo broadcast and PCM output, then goto the Beam Room Settings/Advanced Audio/Surround Settings and slide the TV Level slider bar over to the right hand side. You may want to adjust it back to the middle though for DD 5.0/5.1 surround sound.

Hope that helps a little further.
Ken.
Thanks. I've gone through all the advanced settings and the open and close of my sonos screen. It all seems like it should be working seamlessly but i can't figure it out... works on some channels. Others not. Tv is set to dd.. the channel is sending dd 5.1... but nothing from the surrounds. Do you know if sonos has people that come by and help on site?? Thanks again.
What TV is it and are you using it’s HDMI-ARC, or optical connection? I will have a look at the online manual and see if I can see anything ... I would also perhaps double check that the cable between the TV and Sonos speaker is seated okay... (just in case).

I would have thought the in-built Netflix App would have worked .. try the start of the new Ghostbusters (2016) Movie (just as an example).
Awesome... it's a vizio model D32f-F1. Yes hdmi arc is what it's connected to. Will check the connection..
Okay so your TV is connected to the Beam using HDMI 1 and you should have selected 'Bitstream' for the digital audio out ... have you done that?
No... i will switch that when I'm back at home this afternoon.. thanks for your help. I'll let you know how that works.
Okay .. the Dolby Digital selection in the settings is for Dolby Stereo according to the Vizio manual. The 'Bitstream' digital output setting is for surround sound. Hopefully that will fix your problem. Let me know how it goes.?
Bitstream gave the same result. I did notice dolby 2.0 work with surround. But 5.1 does not. Adjusted in net flix and got surround. But some cable channels are 5.1 and some are 2.0. How do i get the speakers to accept dolby 5.1.
Bitstream gave the same result. I did notice dolby 2.0 work with surround. But 5.1 does not. Adjusted in net flix and got surround. But some cable channels are 5.1 and some are 2.0. How do i get the speakers to accept dolby 5.1.
I don’t know what you mean, sorry? ... the vizio TV manual says for surround sound to set the digital audio output to Bitstream... so it will then output all channels to their respective speakers. So if you Play a Netflix film as an example, that has 5.1 Dolby surround sound, it should just work automatically. Perhaps then try the Auto setting.... see attached screenshot from the manual.
So i set my digital audio on my tv to pcm and the audio in on about my sonos has switched to stereo.. now i get audio from my surrounds on every channel and netflix... not sure if im loosing sound quality but it sounds prety darn good.....
Krylonicon,

If you’re still struggling to get the full surround sound output from the TV, you may perhaps want to speak to the vizio support desk and see what they can recommend for you. If you do decide to do that and eventually get it working, can you kindly let me know the outcome please, just for future reference.

My only other thought at the moment, is that the TV may just support PCM and Dolby Digital stereo audio and that the Bitstream is perhaps more-geared towards the DTS codec rather than Dolby Digital 5.1 surround sound, but perhaps see what vizio have to say about the matter.

A further useful link, perhaps...

https://www.lifewire.com/what-is-bitstream-1846846

A separate issue entirely from the surround sound, but to control your vizio TV with Alexa Voice Controls and CEC... I found this too in the manual on enabling CEC controls over the HDMI port. So you may want to enable that setting too, if you have not done that already.

Hope that helps. ?