Question

Sound cutting in and out on Sonos Arc after playing Dolby Atmos content on Apple TV 4K


Sound cutting in and out on my Sonos Arc after playing Dolby Atmos content on Apple TV 4K 

I’ve had my Sonos Arc and Sub Gen 3 for about two weeks now and I’m very satisfied with the sound quality, but I’m having some very annoying issues with audio cutting in and out… 
I have the latest LG OLED TV, a LG GX (same as the CX, just wall mounted). The only two boxes I have hooked up to my TV is an Apple TV 4K and a PS4 Pro, but I’m having sound issues on my Apple TV.
Before I explain the problem, yes, I’ve pretty much done all the troubleshooting I can do. Plug everything in and out, check that the cables is properly connected, updated everything, the Arc, TV and Apple TV, everything should be up to date as I’m writing this post. 

 

Okay, so here’s the issue, with a half ish solution. 

My issue: 
If I play any content that supports Dolby Atmos on iTunes, Apple TV+, Netflix etc. and try to play some music through the Apple Music app or watch any video on YouTube on my Apple TV after that, the audio cuts in and out every other second. This even happens after playing a Dolby Atmos movie on iTunes and when I go back to the movie menu, the audio starts to cut in and out. It doesn't help to turn the TV and Apple TV on and off and it doesn't help to just restart the Apple TV itself. 

 

The half ish solution:

The only fix that I found that worked, is to play a movie that is in 5.1 after playing Dolby Atmos supported content. If I do that and then go into Apple Music or YouTube, the audio is fine and it doesn't cut in and out every other second. 

 

The issue: 
So it seem like the Arc might have an issue going from Dolby Atmos straight over to stereo sound. But going from Dolby Atmos to 5.1 or from 5.1 to stereo works just fine.
It work perfectly the other way around, from stereo to 5.1 or Dolby Atmos. The only thing I hear then is a little loud zippering or buzzing sound, but I guess that’s just because the Arc is switching the sound receiving signal? If that zippering / buzzing sound shouldn't happen, let me know. 

 

The funny part: 

Here’s the the funny part though, if I play something in Dolby Atmos on my Apple TV and after that play a YouTube video on the built-in YouTube app on the TV, the audio is fine. Same if I AirPlay music to the Arc. So I’m a little unsure if there’s something that has to be fixed from Sonos’s end or Apple’s? 

I’m seeing a lot of people on here tags @Ryan A  and @Kyle A, so I’m gonna do that too, seeing as they come up with a lot of good answers. 

If anyone else has had similar issues, let me know.


102 replies

Userlevel 4
Badge +8

Hello, I’m writing from Colombia.  I have the same problem. LG CX + Apple TV 4K + Sonos ARC + 2 Sonos one LS. LG firmware 03.11.30 no updates 

Can you get the new 3.21.09 firmware, that seems to have fixed the issue you have, not had the issue since installing this firmware on my cx, but did only install it yesterday.

Although this new firmware does dim HDR game mode, and LG have said they will be fixing that in another firmware in the coming weeks, so if you game on the CX you might want to wait for the next firmware. 

Hello, I’m writing from Colombia.  I have the same problem. LG CX + Apple TV 4K + Sonos ARC + 2 Sonos one LS. LG firmware 03.11.30 no updates 

Userlevel 1
Badge

WOW

LG just fixed the issue today they pushed a new firmware.

 

03.21.09

 

fully resolved the Dolby Atmos issues when switching from stereo to Atmos back to strep on Apple TV.

 

So happy, after months of this not working!

Badge

Frustrating that this firmware is not widely available if it fixes the issues.  I am on 3.11.30 and no updates available.

It’s easy to download from the Korean website. 
https://www.lgservice.co.kr/search/driverSoftTotalSearchPage.do?searchKeyWord=2020%EB%85%84%20LG%20%EC%98%AC%EB%A0%88%EB%93%9C%20AI%20%EC%B5%9C%EC%8B%A0%20%EC%86%8C%ED%94%84%ED%8A%B8%EC%9B%A8%EC%96%B4_OLEDxxCXX_GXX_O20)&oneCateCode=1005&twoCateCode=D002795

 

select the first option All Red = OLED

I saw a couple of people on the LG forum did this and said it did not fix the issue.  Can you verify that it worked for you?   I am just a little leery of installing a potentially unsupported firmware, and then have something else go wrong on a $3500 TV and not get support from LG.    
 

granted I’ve only had the update for a day but so far so good! The soundbar going out for 2-3 seconds issue has not popped back up!
 

The Apple TV issue with atmos and stereo sound cutting in and out has been resolved for sure  

 

Frustrating that this firmware is not widely available if it fixes the issues.  I am on 3.11.30 and no updates available.

It’s easy to download from the Korean website. 
https://www.lgservice.co.kr/search/driverSoftTotalSearchPage.do?searchKeyWord=2020%EB%85%84%20LG%20%EC%98%AC%EB%A0%88%EB%93%9C%20AI%20%EC%B5%9C%EC%8B%A0%20%EC%86%8C%ED%94%84%ED%8A%B8%EC%9B%A8%EC%96%B4_OLEDxxCXX_GXX_O20)&oneCateCode=1005&twoCateCode=D002795

 

select the first option All Red = OLED

I saw a couple of people on the LG forum did this and said it did not fix the issue.  Can you verify that it worked for you?   I am just a little leery of installing a potentially unsupported firmware, and then have something else go wrong on a $3500 TV and not get support from LG.    

Userlevel 4
Badge +8

Frustrating that this firmware is not widely available if it fixes the issues.  I am on 3.11.30 and no updates available.

Yeah as above if in US it seems you can install the Korean firmware, but overall looks like it was a small push of updates early in the week to a select few, likely they will push to TVs in the new year now or hopefully upload to the website to download and install manually.

Badge

Frustrating that this firmware is not widely available if it fixes the issues.  I am on 3.11.30 and no updates available.

It’s easy to download from the Korean website. 
https://www.lgservice.co.kr/search/driverSoftTotalSearchPage.do?searchKeyWord=2020%EB%85%84%20LG%20%EC%98%AC%EB%A0%88%EB%93%9C%20AI%20%EC%B5%9C%EC%8B%A0%20%EC%86%8C%ED%94%84%ED%8A%B8%EC%9B%A8%EC%96%B4_OLEDxxCXX_GXX_O20)&oneCateCode=1005&twoCateCode=D002795

 

select the first option All Red = OLED

Frustrating that this firmware is not widely available if it fixes the issues.  I am on 3.11.30 and no updates available.

Userlevel 2
Badge

This is apparently fixed on the LG CX with new firmware (3.21.09), only available in some regions at the moment though.

 

Confirmed, this is fixed in LG CX firmware 3.21.09 :)

Badge

This is apparently fixed on the LG CX with new firmware (3.21.09), only available in some regions at the moment though.

 

Good to hear!

Userlevel 4
Badge +8

This is apparently fixed on the LG CX with new firmware (3.21.09), only available in some regions at the moment though.

 

Having this exact issue - any updates yet? I’m fairly sure it’s related to the AppleTV only.

Problem occurs for me when:

  1. Watch any Atmos content (typically Disney+ is easiest)
  2. Atmos sound works fine
  3. Back out to YouTube app (or any non-Atmos app)
  4. Sound doesn’t work, goes in/out every second
  5. Return to Disney+
  6. Even Atmos sound is broken at this point

If I change to any other device via HDMI, the sound works just fine, even if using Atmos. Typically I’ll just move to my built in TV apps until the issue eventually fixes itself.

Badge

I’m resigned to just use the WebOS YouTube and streaming apps. I’ll likely only use Apple TV for apps that aren’t available on WebOS. 
 

However, when streaming Netflix or any other Dolby vision show, I’ve noticed at times it will drop audio coming from the Sonos arc for 2-3 seconds, revert to TV audio, and then revert back to the arc. My LG CX flashes HDMI port 2 now available as if it was temporarily disconnected. Does anyone else experience this? 

As some others have said on this thread, fairly certain this is not a Sonos issue as I was experiencing it before my Arc Arrived. It’s an Apple TV problem from what I can tell. This thread offers some help (workaround): https://discussions.apple.com/thread/251880434

 

 

FYI, this is definitely not a SONOS issue.  Unplugged the HDMI ARC to the Sonos and you’ll see the the LG tv does the same audio stuttering.  This is an LG tv and Apple TV issue.  It’s just that so many people have this LG CX, Apple TV and Sonos combo that people naturally blame the speaker system.

Agreed. I had this issue prior to receiving my Arc. The chirp is new however and may be specific to the Arc. Anyone have recommended updates/workarounds taking in account that LPCM should now be supported?

Badge

I have just re tested the google TV chromecast and the problem has been solved! 
 

I used atmos and then switched to YouTube on the google TV chromecast and no sound cutting in and out! Miracle! 

Badge

I think the issue is with the Sonos arc itself. I have tried multiple devices, including Apple TV 4K, Roku ultra, and also Google TV chromecast on my LG 77 Cx.  All of them have the issue of the sound cutting in and out after playing Dolby atmos and then playing YouTube. Surprisingly if I play atmos and then another app like CNN go, the sound does not cut in and out. It may be an issue with the YouTube app on third party streamers? 
 

 

Userlevel 4
Badge +8

I just noticed they released an app update 12.2.2 yesterday and also a system update 12.2.2, has anyone had the chance to see if it fixes any audio issues?

It didn’t fix the issue. Brought support for adding a second sub. No update around this issue yet. Hopefully will be fixed soon. 

Thanks for checking. I thought it might fix it as I think they said December for a fix.

I just noticed they released an app update 12.2.2 yesterday and also a system update 12.2.2, has anyone had the chance to see if it fixes any audio issues?

It didn’t fix the issue. Brought support for adding a second sub. No update around this issue yet. Hopefully will be fixed soon. 

Having a similar issue. Trying to play other content then coming back works sometimes. Disappointed after just dropping so much for this setup. LG CX/ Apple TV 4K/ARC + SUB 3 + 2 One SL

Userlevel 4
Badge +8

I just noticed they released an app update 12.2.2 yesterday and also a system update 12.2.2, has anyone had the chance to see if it fixes any audio issues?

Userlevel 4
Badge +8

I

They replaced my arc as well. Didn’t fix the issue. They released a half baked product that is having issues with Atmos and the only option is to turn off eArc or don’t use atmos. Makes no sense. 

I requested an update today and here is the response. It’s purely comical.
 

There is no update to share at this time. As previously stated this will likely take some time and I will reach out if there are any updates available or things for us to try. Work is being done towards improvement with the Arc system but this is not a fast process. The offer is still open to return/buyback your 5.1 system if you would rather not wait for our developers to work this out.

Thank you,
Brandon G

Sonos Escalations Team

It is a bit comical isn't it, what gets me is the response from Sonos on the issues, they don’t keep us informed enough, every now and then it would be nice if they posted an update on the progress on these threads.

 

They replaced my arc as well. Didn’t fix the issue. They released a half baked product that is having issues with Atmos and the only option is to turn off eArc or don’t use atmos. Makes no sense. 

I requested an update today and here is the response. It’s purely comical.
 

There is no update to share at this time. As previously stated this will likely take some time and I will reach out if there are any updates available or things for us to try. Work is being done towards improvement with the Arc system but this is not a fast process. The offer is still open to return/buyback your 5.1 system if you would rather not wait for our developers to work this out.

Thank you,
Brandon G

Sonos Escalations Team

Same issue here with CX, Appletv 4K, and new arc arriving today. 

This has been replicated on my Sony A1E 65 and 55, LG GX77, LG 77G7, LG CX48. Without the Apple TV as well for the “audio in and out”.  The chirp from Atmos to non atmos only happens with eArc is on.  Sonos confirmed this is their issue. Like i said before this has been escalated all the way to Patrick Spence and confirmed it’s a Sonos issue and a fix is in the works. 

Additionally the only two TVs I have that support eArc are the GX and CX. 

Reply