Sonos Sony Bravia KDL60W630B and 5.1 with U-Verse and PS4

  • 5 August 2017
  • 1 reply

  • Contributor I
  • 4 replies
Wanted to share this with the community in case others are looking for answers. I recently purchased a Sonos 5.1 setup and unbeknownst to me there are some specific things to look for to get 5.1 audio to the Sonos system which are discussed at length on this forum. I wanted to be specific to a setup in case others have the same.

Luckily, my Sony Bravia KDL60W630B passes through Dolby Digital 5.1 sound from HDMI inputs to the optical out. They key is ensuring the TV and source systems are configured to pass the right type of audio. The only thing you need to do on the TV is ensure the audio settings are configured to output to "AUDIO SYSTEM". HOME->SETTINGS->AUDIO->SPEAKERS->AUDIO SYSTEM. I've ready that many recent (last 5 years or so?) Sony TVs will pass 5.1 through optical from HDMI. Sony support will gladly answer this question for your specific model.

My cable box (u-verse) is now set to output Surround Sound (it was set to stereo before) and on most channels my Sonos app says it's receiving either Dolby Digital 2.0 or 5.1 based on the soundtrack of what we're watching.

Next, I configured my PS4 to output Dolby Digital 5.1 (select Bitstream). This worked for games and such but blue-ray movies still output whatever's default for those movies. That said, while watching the movie you can tweak the sound output settings. For example, was watching John Wick 2 last night and although the main PS4 settings were to output 5.1 the moving was still outputting DD Atmos (I think) so my Sonos was showing it was receiving stereo. While watching the movie, I simply changed it to Bitstream (Direct). To do this, tap Options on the PS4 controller while watching the movie. Scroll over to "settings" then look for Audio Format. Simply select Bitstream (Direct) then you can confirm in the Sonos app that it is in fact receiving Dolby Digital 5.1. Problem solved.

The last thing I need to do is figure out my Apple TV 2nd gen. So, on most media from Netflix, iTunes store, etc. it shows up in my app in the right format (DD 5.1). However, certain movies (e.g. John Wick 2) only pushed stereo audio. I'm thinking there has to be a setting somewhere that I am missing. In the Audio settings for Apple TV there are two options. Audio Output and Dolby Digital. I changed Dolby Digital to ON from AUTO but didn't notice any change. I also changed Audio Output from AUTO to 16 bit but that didn't do anything so I left it on AUTO. If the Apple TV is anything like the PS4, I wonder if there's an audio setting you can change while specifically watching a movie. More to come...

Hope this helps.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 4
Badge +3
Hi stil, thanks for posting this. It seems you've done everything how we would recommend it. I expect this post will be very useful for many other users in similar situations.