Answered

Sonos Playbar only shows Stereo PCM 2.0

  • 1 January 2021
  • 32 replies
  • 5016 views

I have

 

Media source: Apple TV (3rd Gen) 

Video Player: Optomo UHD52ALV Projector connected through HDMI from Apple TV

Audio: Sonos Playbar (set up as surround sound with sub + 2 Sonos One) and Connected through Optical cable from Apple TV 

 

When I play Netflix on Apple TV and choose audio English [Original] (5.1) or Amazon Prime to choose a movie with “Dolby Digital Plus” The Sonos app shows the Audio IN as “Stereo PCM 2.0” in both cases.

Checked Sonos App for System Update and shows “Your Sonos system is up to date”.

Bought this audio splitter https://www.amazon.ca/gp/product/B07JDGBBXF/ref=ppx_yo_dt_b_asin_title_o03_s00?ie=UTF8&psc=1 and cant get the 5.1.

Is this even possible?

 

icon

Best answer by GuitarSuperstar 1 January 2021, 03:32

I have an Apple TV (Gen 3) connected through HDMI. I just tested Jack Ryan on Prime Video. I believe Prime is limited to Stereo 2.0 on the Apple TV (Gen 3). I can get Dolby Digital 5.1 through Netflix though. I imagine it should  work through optical too.

View original

32 replies

What are the audio settings on the Apple TV itself? Those settings would override the settings for the individual apps.

I can tell you that Dolby Digital Plus can not be sent across the optical cable, it maxes out at Dolby Digital. 

The Settings under Audio & video on the Apple TV are:

Dolby Digital   - “Auto” and the options are “On” “Off” or “Auto”

Audio Output is set to “Auto” on Apple TV.  The options are “Auto” or “16 bit”

Userlevel 7

I have an Apple TV (Gen 3) connected through HDMI. I just tested Jack Ryan on Prime Video. I believe Prime is limited to Stereo 2.0 on the Apple TV (Gen 3). I can get Dolby Digital 5.1 through Netflix though. I imagine it should  work through optical too.

Badge

My Sonos Playbar shows as PCM too (in the Sonos app) but the TV audio out is set to Dolby Digital.  The TV model is a Sony XBR65X900F.  Is the app auto detecting the source audio?

Badge

I am also having an issue with my playbar where the sound stops all together after 5-10 seconds when the TV is turned on.  I have the auto feature on.  The funny thing is, is that if I click on another source (on the tv, such as hdmi and then back to cable) the sound comes back and is fine.  I have an open case with Sonos support but they haven’t found a solution.  I’ve also been looking up on this forum as well as reddit about issues people are having with the Playbar, and in most cases, the Sonos rep stops replying and the problem is never resolved.  What a crappy service for a ‘premium’ soundbar.  I also have 2 Sonos One’s as the rear surrounds and a sub.  I also have 2 Sonos One SL’s in my bedroom.  At this point, I’m considering getting rid of all my Sonos speakers.  The rep that was helping me said there is a latency issue.  How can there be a latency issue when I am able to play music and spotify with no issues, its only when the TV is on where I’m having the issue.   It’s really annoying having to change sources back and fourth every time.  Also, the Playbar is hard wired to the TV via optical, so once again, how can there be any latency issue?

Userlevel 7

My Sonos Playbar shows as PCM too (in the Sonos app) but the TV audio out is set to Dolby Digital.  The TV model is a Sony XBR65X900F.  Is the app auto detecting the source audio?

 

The app will detect whatever audio the source is sending and the TV can pass through. What specific content are you watching and from which app and device?

Badge

to add, the problem only started since the last update.  The Sonos rep is blaming my network but as seen in all other posts about the Playbar, that is all they do and then stop replying.

Badge

My Sonos Playbar shows as PCM too (in the Sonos app) but the TV audio out is set to Dolby Digital.  The TV model is a Sony XBR65X900F.  Is the app auto detecting the source audio?

 

The app will detect whatever audio the source is sending and the TV can pass through. What specific content are you watching and from which app and device?

I am using an android box for IPTV.  It was working fine up until the last sonos update.  Nothing has changed on the android box.

Userlevel 7

Have you ever been able to get Dolby Digital 5.1 from your IPTV apps through your Playbar? I would be surprised if any of those apps supported multichannel audio.

Badge

Have you ever been able to get Dolby Digital 5.1 from your IPTV apps through your Playbar? I would be surprised if any of those apps supported multichannel audio.

I’m not sure to be honest, but the problem is that the sound just stops after 5-10 seconds then I have to click on cable on my tv remote again and it works fine after that.  But why does it work for the first 5-10 seconds and then stop?  This problem only started since the last update.

Badge

I’ve also toggled auto play on and off to see if that made a difference, it didn’t.  I even tried my Bose sound bar when the sound cuts out from the Sonos using the same optical cable, and there is sound when I plug in the Bose, just doesn’t work with the Sonos.  

Userlevel 7

Have you ever been able to get Dolby Digital 5.1 from your IPTV apps through your Playbar? I would be surprised if any of those apps supported multichannel audio.

I’m not sure to be honest, but the problem is that the sound just stops after 5-10 seconds then I have to click on cable on my tv remote again and it works fine after that.  But why does it work for the first 5-10 seconds and then stop?  This problem only started since the last update.

I was only addressing the Stereo PCM issue.

Have you tried unplugging the Playbar and the TV or disconnecting the Playbar and going through the setup process again?

Badge

I’ve done a hard reboot of the tv and also factory restored it.  I haven’t factory reset the playbar yet.  The problem just started happening a few weeks ago with the Sonos update.  I guess that’s my only option left at this point.  What a shitty product.

I have the same issue... App shows stereo pcm.   Have a Samsung TV and input via ps 4 for netflicks, Disney and prime plus Virgin media from ts own box. I used to get real 5.1 surround but now  just get stereo... Nothing changed except updates to sonos. I have playbase, sub and 2 play 1s...any reason why the 5.1 is suddenly stereo... Can be dsney, Netflix, Virgin and prime all hav e developed issues at the same time?

 

Thanks

All. Connected via hdmi and fibre 

 

Has anyone come across a solution for this as yet? I only got my Sonos Arc, Sub and 2 Play 1’s a couple of weeks ago and no matter whether I use my Sky box, or Apple TV, I only get Stereo PCM 2.0. I have yet to see Dolby Digital or get anywhere near 5.1. Is it something I’m doing wrong or is it the Sonos system? 
The Arc is plugged into my HDMI ARC port on a Samsung ue55d6530. Thanks. 

Userlevel 7

Has anyone come across a solution for this as yet? I only got my Sonos Arc, Sub and 2 Play 1’s a couple of weeks ago and no matter whether I use my Sky box, or Apple TV, I only get Stereo PCM 2.0. I have yet to see Dolby Digital or get anywhere near 5.1. Is it something I’m doing wrong or is it the Sonos system? 
The Arc is plugged into my HDMI ARC port on a Samsung ue55d6530. Thanks. 

What are the audio settings set to on the TV, Sky, and Apple TV?

Has anyone come across a solution for this as yet? I only got my Sonos Arc, Sub and 2 Play 1’s a couple of weeks ago and no matter whether I use my Sky box, or Apple TV, I only get Stereo PCM 2.0. I have yet to see Dolby Digital or get anywhere near 5.1. Is it something I’m doing wrong or is it the Sonos system? 
The Arc is plugged into my HDMI ARC port on a Samsung ue55d6530. Thanks. 

What are the audio settings set to on the TV, Sky, and Apple TV?

I think I may have found the issue. My tv settings were set to PCM, but in order to find that and access that part of the sound menu, I had to disconnect the arc from the tv to allow me in. Once I had changed it, I plugged the arc back in and I’m now showing Dolby Digital 5.1. So hoping that’s it sorted 🤞

Badge

Sam issue , I've just got a playbar and 2 play ones , my tv and sky q (2tb box) audio is dolby digital,  the play ones work for about 10 seconds then cut off they also drop sound every few seconds,  not paying all this money for them to do this , sound bar is fine that's always fine just the play ones that keep playing up 😡😡😡

Userlevel 7
Badge +17

This does not seem like the same issue. Surrounds dropping is mostly related to wifi interference, and since the surrounds are connected to the soundbar via a dedicated 5Ghz link, the interference is probably in that band…..

Badge

Why does my play ones only work for some things , such as , I could have sky sports on then they would stop If i change the channel and go back to sky sports it works again plus i dont use 5Ghz my smart lights and stuff will only work on 2Ghz.

Userlevel 7
Badge +17

Maybe Sky Sports does DD 5.1 and the other channel doesn't? What does the app say the Playbar is receiving in both circumstances?

Badge

It was working the other day as I watched football and the play ones were working fine , if you know the music that comes on sky sports news when theres a break that works but when they start speaking it's just coming from the playbar , in sonos system info it says the bars audio is stereo PCM 2.0 

Userlevel 3
Badge +6

Dialog typically only comes from the centre speaker in a surround sound setup, in this case the centre drivers of the playbar. Music, been more of ambient sound will often bemixed to the surround speakers.

 

As mentioned you might want to check in the app for what is being played and whether the surrounds are dropping out or not.

Badge

How do I check , I'm new to all this sonos stuff 😂😂😂

Reply