Sonos Issue / LG Issue or idiot owner Issue


O.P.

Hi folks,

I have an LG  CX 65" OLED TV for which I just bought a Sonos Arc. My problem is that, if I plug it in to the eARC HDMI port as recommended, I don't seem to be able to select any other sound output channel. Now you may wonder why I would want to do this and I have an answer.

I often need to be able to use headphones when watching TV late at night or when with my wife – I'm partially deaf and this allows me to enjoy watching without driving her to deafness too. However, choosing "wired headphones" or "wired headphones + internal speakers" in the audio output menu doesn't stick. It just switches back to "HDMI ARC" after a few seconds.

I have gone through every setting I can find in the iOS app from Sonos and didn't find anything helpful. I managed to make it work only by unplugging the HDMI cable from the Sonos. I haven't tried other options such as using another HDMI input – perhaps that would help?

If anyone can point me at what idiotic thing I'm doing wrong I’d be very grateful. Hopefully I haven't bought the wrong soundbar?

Thanks for listening.

Cheers, Grant


6 replies

Userlevel 4

From the “General Settings” manual, just set the “CEC” as off whenever you want to use other outputs instead of eARC.

Userlevel 7
Badge +17

In LG terms HDMI-CEC is called Simplink.

Would the Arc stille work using this work around (that, reading this forum, is indeed the only work around in your set up when  not switching over to optical)?

Thanks Guys for the help. I managed to “chat” with an LG rep online in their support site. He also directed me to switch off Simplink. That worked and I had the ability to select other output channels. 
 

However, I’m now unable to get Simplink working again. The situation now is that selecting HDMI ARC as the audio output produces a message (top right of screen) saying that Simplink has been turned back on. Checking this, through the Settings, shows that it is selected again. That would be quite convenient - if it worked. As I understand it, selecting HDMI ARC and activating Simplink should give me control of the sound-bar with the TV remote. It doesn’t. 
 

I went through the whole remote set up procedure and still cannot control the volume of the Sonos with the TV remote. Obviously, even if I can get it working again, this is not exactly something I’d be prepared to do routinely so it’s not really a solution. 
 

I’ll try to do this with another LG rep when time allows and see if we can fix it. I’ll report back if I get a solution. 

Again, thanks for the input. 

Userlevel 7
Badge +17

Though it adds another step to the program, have you tried rebooting the Arc?

Userlevel 4

To control the volume of your SONOS Arc, you have to set it with the SONOS app as I remember…

 

Whenever you switch the audio output to HDMI ARC, the Simplink will turn back on… So you have to manually turn it back off when you want to use your headphones.

Userlevel 7
Badge +17

@wilwong829 With HDMI-CEC, the TV will control the volume of the Arc (as it does with my Beam). No need to set it with the Sonos app.

@Grantxw8 If you are not bothered by the loss of Atmos, you could try to connect the Arc to your TV via optical using the Sonos adapter (of which I do not no if it comes with the Arc). You would than also need to link the TV remote to the Arc.

 

 

Reply