Answered

Sonos Beam No Sound From LG TV

  • 19 July 2018
  • 9 replies
  • 12614 views

Hello, first post so please go easy!

I received my Beam on launch day and setup seemed to be a breeze. I managed to integrate it into my system (2 other Play 1s) and music plays (still plays) without issue.

The issue seems to be with the connection to my LG TV. Initially this all worked, sound was good and Alexa turned it off/on and adjusted the volume. After a couple of hours use the Alexa control over the TV seemed to stop working but the TV sound was fine. Then the TV was turned off via the remote and since turning it back on the speaker does not output any TV sound - music/radio can still be played via the Sonos app.

I’ve checked my settings and confirmed HDMI ARC is selected and CEC is on. I’ve tried powering down both the TV and the Beam and also repeatedly used the app to connect the speaker.

When I try to test the Simplink connection I see a HMDI 2 (ARC) pop up on the screen but then the test fails - I’ve tried this repeatedly and get the same results.

When this speaker was working I was really impressed with it - please can someone point me in the right direction?!?
icon

Best answer by thompsp22 20 July 2018, 22:34

Ryan

Thanks for getting back to me - your suggestion has fixed my problem. I used my own HDMI cable which is either faulty or not to the same spec as the Sonos supplied one.

I’ve swapped this out and the speaker works perfectly - TV sound / all Alexa controls - happy again :)

Thanks

Paul
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Userlevel 7
Badge +26
Hi! Welcome to the community. To start with, I'd suggest checking if you have CEC turned on for any other devices connected with your TV that might have taken over control from the Beam. If you can, try unplugging everything HDMI connected to the TV except for the Beam. Reboot everything, then try setting it up again, and finally, reconnect everything.

Let us know how it goes.

Also, what's the model of the TV that you have and it's firmware version?
Ryan

Thanks for getting back to me. My setup is very simple...only one HDMI in use and that’s to the Beam. It’s definitely connected to the ARC HDMI and CEC is on. I’ve spent about 3 hours fiddling with settings and rebooting/powering down etc. Strangely TV sound started to come out of the speaker after I pressed and held the connect button at the back of the speaker. The indicator flashed white, green and red for a period after this but the microphone for Alexa was disabled. On re-enabling Alexa the sound went back off and the same issues were then encountered.

A bit disappointed really as previous Sonos products have just been plugged in, setup and then no issues. Any further help would be greatly appreciated!

Paul
Hi Paul,

Have you switched the SIMPLINK on via the LG TV settings menu, I had the same issue and sound won't come out of the speaker unless this is turned on for it to be fully connected.

Ross
Hi Paul,

I have sound and can adjust TV volume but beam will not turn TV off or on reliably


Mine is LG
MODEL : 55EG910T
Hello

Yes Simplink is on - my model is LG 55UH668V.

I opted for phoning Sonos and we went through various things. Ended up powering the TV down and unplugging, leaving for 2 mins and having the HDMI disconnected from the Sonos. Powered back up and reconnected everything - had to re-link Alexa via the app. This seemed to sort it, unfortunately 30 mins later it all stopped again, now back to TV internal speakers. Alexa still works but at the minute it’s a very pricey Echo...I’ll have to phone them again...

Paul
Userlevel 7
Badge +26
Hi Paul, when you go to the TV settings, is the audio set back to the internal speakers or does it still show the external device?

For LG, the basic settings should be here:
Turn on Settings > Sound > Sound Out to External Speaker: (Optical/HDMI Arc)
Also, for some TVs you may need to go to the Smart/Home menu > Select 'my apps' > SIMPLINK icon > Turn on.

Do you have another HDMI-ARC CEC cable that you can test out with the Beam to see if it's an issue with that cable?
Ryan

Thanks for getting back to me - your suggestion has fixed my problem. I used my own HDMI cable which is either faulty or not to the same spec as the Sonos supplied one.

I’ve swapped this out and the speaker works perfectly - TV sound / all Alexa controls - happy again :)

Thanks

Paul
Userlevel 7
Badge +26
Great to hear! Let us know if anything else comes up, and I hope you enjoy!