Sonos beam + HDMI ARC on Receiver

  • 28 July 2019
  • 5 replies

Hi Folks,
I have an older TV which has no HDMI ARC out but does have an optical out. In spite of my best efforts in getting an 5.1 signal to Beam, I have been unable to do so. Here's what I tried:

  1. I have a Roku unit which streams Amazon Prime video & Netflix, I verified that Roku is sending out 5.1 signal to the TV for a movie being streamed in 5.1. But the audio in to Beam always shows stereo output. It looks like the TV is somehow modifying it to stereo output.
  2. Same when I connect a Blue Ray signal to the TV.
  3. I do have an inherited Receiver which has a HDMI ARC out. I was wondering to connect it to the Beam instead of the TV. The plan is to connect the devices to the receiver and using the HDMI ARC out to the Sonos Beam. Granted, the receiver is not being used much here but I thought it would be a good test to see if that changes anything.
I tried to look in to the manual of the TV and see that when I move the sound output to non-TV speakers (to the connected Beam), the options for modifying sound in the TV setup get grayed out. In other words, I am unable to see what the TV is doing with that signal.

Does anyone have ideas how I can get a 5.1 signal out to my Beam? Does step 3 sounds like an ok plan (yes I am aware having a receiver in there is not the best of ideas).

PS: for the sake of completeness, I have a Sony KDL-40WL140 TV and the receiver is a Yamaha HTR-4065. Diagnostics confirmation number is 2108532076.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

You’re not being clear enough when you say “5.1”, as there are several different versions of 5.1.

I certainly think connecting the Beam to the receiver with HDMI-ARC is a good way to test if the problem may be the TV, but it still may be that 5.1 signal you’re claiming. Sonos can deal with only Dolby Digital. Not DTS, not Dolby Digital Plus, not Dolby Atmos (which isn’t really 5.1 either)

You haven’t listed what TV you have, but I’m going to hazard a guess that it isn’t capable of passing through a Dolby Digital signal through the optical output, since you say it is “older”. You could consider the receiver as one potential, or an HDMI switch, as discussed in many posts in this area of the community, in order to get that Dolby Digital signal to your Beam.
Userlevel 7
Badge +17
To use external speakers go to Sound System, Speakers, and set to Audio System. The optical output will send a PCM/Dolby Digital signal, depending on the signal it’s receiving.

Make sure youve selected an HD channel AND ITS BROADCASTING A DD PROGRAM - some HD programs are still only broadcast with stereo sound.

In the Sonos app look in Settings, About my Sonos System. In the section for your Beam it should show Dolby 5.1.
Userlevel 7
Badge +17
Another thought: can your blueray player output a Dolby Digital signal? Not DTS etc: it must be DD. If so, plug the HDMI out from that to to Beam, just to test audio without the Sony TV in the loop.
@Airgetlam - By 5.1 I meant Dolby Digital. Also, for the TV/Receiver info, I mentioned it in the "PS" section of the post above along with diagnostics confirmation number. Thanks for the info on the receiver...I will check it out tonight.

@nik9669a - The steps I mentioned in "1" and "2" were with external speakers set to Audio System. The problem I have is that when I switch to Audio system, the TV automatically superimposes a "Clear Voice" option as my audio choice and grays out everything else. And looking at the "About my Sonos System" is how I found out I was getting stereo (I wouldn't just trust my ears, I have been fooled on this before :-)) with this "Clear Voice" option. On the plus side though, the dialogues sounded very clear :-)

I think using an HDMI switch or using the HDMI-ARC passthrough sounds like a good next step. I will keep everyone posted on my progress. Thanks everyone!
Userlevel 7
Badge +17
If the tv station you have selected is only broadcasting a standard program, you will only get stereo.

You must be watching one of the HD channels, AND it MUST be broadcasting a DD program. A lot of audio, even on HD broadcasts, is only stereo.

I don't think Clear Voice is an issue.