Answered

Sonos Arc not always detected

  • 5 January 2021
  • 3 replies
  • 72 views

I have recently purchased a Sonos Arc and a new TV to go with it, the LG nanocell 91 with eArc. This all works fine and I get Dolby Atmos and 5.1 coming through the Arc from appropriate sources and it all sounds great. So far so happy!

The problem is that around one time in 4 or 5 the Arc does not seem to be detected and the TV defaults to its internal speakers, there does not seem to be any consistency or pattern to when or why this happens at all. I am using the HDMI cable that came with the Arc and have tried a different high quality cable as well which makes no difference, I have also tried adjusting all potentially possible settings on the LG TV as well.

Has any one else experienced this or even better found a way to fix it?

Many thanks in advance!!

icon

Best answer by Ken_Griffiths 5 January 2021, 23:24

I would certainly try a different HDMI cable with the Arc, but this issue can sometimes be caused by another device connected to the TV HDMI ports, where the device is also using HDMI-CEC, that occasionally tries to steals the focus away from the Arc. Simplink then gets confused and when that happens the TV defaults back to internal speakers. A simple toggle off/on of Simplink might quickly sort the matter and perhaps try toggling off/on eARC on the HDMI port - the audio on the ports is also perhaps best set to ‘pass-through’, rather than auto. 
 

Anyhow, I would suggest disconnecting any other HDMI connected devices from the TV just to first see if the issue goes away ...and then plug each one back in (one at a time) to see if any device starts to cause the problem again. If so, switch off the HDMI-CEC feature on that device, or if that’s not possible, then add a CEC-Less adapter to its cable connection, similar to the example shown in the link below:

https://www.amazon.com/Lindy-HDMI-Adapter-Female-41232/dp/B00DL48KVI

View original

3 replies

I would certainly try a different HDMI cable with the Arc, but this issue can sometimes be caused by another device connected to the TV HDMI ports, where the device is also using HDMI-CEC, that occasionally tries to steals the focus away from the Arc. Simplink then gets confused and when that happens the TV defaults back to internal speakers. A simple toggle off/on of Simplink might quickly sort the matter and perhaps try toggling off/on eARC on the HDMI port - the audio on the ports is also perhaps best set to ‘pass-through’, rather than auto. 
 

Anyhow, I would suggest disconnecting any other HDMI connected devices from the TV just to first see if the issue goes away ...and then plug each one back in (one at a time) to see if any device starts to cause the problem again. If so, switch off the HDMI-CEC feature on that device, or if that’s not possible, then add a CEC-Less adapter to its cable connection, similar to the example shown in the link below:

https://www.amazon.com/Lindy-HDMI-Adapter-Female-41232/dp/B00DL48KVI

Thanks for the ideas Ken!

I have tried different HDMI cables and restarting all devices as well as toggling on / off relevant settings. I only have one other HDMI device connected (a cable TV box) which I have now switched off HDMI CEC, and have audio set to pass-through…

But none of this seems to help, every now and then the TV defaults to its Internal Speakers and my Arc and surround speakers (Symfonisk bookshelves) are just gathering dust…

If anyone else has any other ideas or are experiencing the same problem then please share!! Otherwise, I guess I will open a ticket with Sonos support…

Many thanks!

How about if you switch off ‘auto-device detection’ and/or ‘auto-power-sync’ in the connection settings on the TV. Maybe see if either of those make any difference.
 

I’m assuming you have the latest TV firmware too?

Reply