Question

Sonos arc doesn't show splash screen on TV

  • 3 August 2020
  • 5 replies
  • 135 views

  • Contributor I
  • 2 replies

Bought myself a brand new Sony TV with eARC connection (tv model 55x950g/55xg9505). I've notice that when I put on display the Sonos arc HDMI input, there is no splash screen on TV. Just black screen with message that there is no video signal. Few days ago I had a picture, and later notice that the picture was changed and looks like there is a kind of error.

Also, after setup Google  home app, the app show a new device named "Sonos tv control", that can't connect (connection failure), as can be seen attached pic to this thread.

Atmos and streaming music works well most of the time. However, once in a while there is no sound output from the arc, only after I change the sound settings from Auto 1 to Auto 2, and then get back to Auto 1... Kind of annoying bug.

TV runs Android pie 9.0.

Not sure if  my Sonos arc or the TV is the problem. 

walkthrough will be welcome! 

Thanks. 

 

 


5 replies

Userlevel 5
Badge +16

Hi @Idov.

Welcome to the Sonos community and thanks for reaching out to us. Thank you for the detailed response and for performing some troubleshooting steps.

I would like to share with you the manual of your Sony TV. Based on the manual, eARC or ARC port is neither of those HDMI options you have provided. Based on the manual HDMI eARC or ARC port is HDMI 3. I would suggest making sure the Sonos ARC is connected to the right eARC or ARC port on the TV to be able to utilize the functionality of the Sonos Arc.

Please let me know if it works. We are always here to help.

Thanks,

Thanks @Paul A for your reply.

My Sonos arc is connected to the HDMI 3 input, and sound comes out from the arc (including Atmos).

When I first install the Sonos arc and watch TV from HDMI 3 input, I saw the splash screen. Now just no video signal is out from the arc.

 

Userlevel 5
Badge +16

Hi @Idov.

Thanks for the detailed and immediate response.

I would recommend submitting a diagnostic while the issue is re-occurring for us to check what is going on with the Sonos Arc. I would also recommend unplugging the HDMI from the back of the Sonos Arc and from the back of the TV and then plug it back (while the TV is turned off) then once the HDMI cable is plugged back into the TV and the Sonos Arc, plug the TV into power and plug the Sonos Arc into power. Lastly, test to make sure if any positive results occurred and if the issue is fixed.

Please let us know if you still have further questions or concerns. We are always here to help.

Thanks,

Hi, @Paul A problem was kind of fix now! Splash screen returned, but after few seconds starting to change.. look at the picture.

After your walkthrough, I tried to setup the tv with the Sonos app, and got failure.

Diagnostic before the fix 28566630

Diagnostic after fix (with the tv setup error) 325221172

 

Userlevel 5
Badge +16

Hi @Idov.

Thanks for submitting diagnostics and for your immediate response.

I would like to share with you, based on the submitted diagnostics before the fix the diagnostic shows that the Sonos Arc is detecting audio via ARC option which is disabled from the TV since you have the TV on eARC mode and after the fix, ARC audio detected has been fully disabled.  It seems the TV is alternatively switching from ARC to eARC and vice versa. I would recommend reaching out to the manufacturer’s technical support team and check if the TV may need some updates or what needs to be done for the TV to stop switching from ARC to eARC and vice versa. If the TV is set up broadcast audio through eARC and since the ARC option is disabled, it should not switch from eARC to ARC which it is doing even if ARC is disabled.

I hope this helps and gives a little light on the situation.

Please do not hesitate to reach out if you still have further questions or concerns. We are always here to help.

Thanks, 

Reply