Question

Sonos Arc

  • 2 September 2020
  • 31 replies
  • 570 views

Badge

Sonos arc connected to sony tv when try to select tv speakers it jumps back to audio system?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

31 replies

That’s the way ARC is designed to work, it has nothing whatsoever to do with Sonos. If you want to use the TV’s speakers instead of an ARC device, you need to turn off HDMI CEC, which carries the ARC signal back and forth. Then the TV won’t ‘see’ any connected speaker, and will allow (force) the use of the internal speakers. 

Badge

I was in the Richer Sounds shop today and the one there worked properly, same set up.

Badge

Same issue for me with Sony A9G, I turned Audio Output->Speakers→ TV Speakers.  It switches for a moment and then reverts back to External speakers.  I tried turning eARC mode to Off just for the TV and it’s still external speaker. Not sure where HDMI CEC is or if it’s called something else on the Bravia. 

Badge

I have a Sony 8A similar model to yours, the tv in the shop was a different model, it may be an issue with these models, if you find solution please let me know.

Badge

@Airgetlam, ideas on what else CEC might be called?  The Sony site doesn’t give much in terms of the setup of this part specifically beyond what we’ve tried.  I can also ask other Sony/Sonos users in their forum.

It’s been years since I worked for Sony, let me go look at a manual.

Badge

I had the Sony help people remotely go through the settings on my tv, they found nothing wrong and referred me to Sonos.

Looks like the call it what it is, eARC. Oh, and BRAVIA Sync.

See https://www.sony.com/electronics/support/televisions-projectors-oled-tvs-android-/xbr-65a9g/articles/00137387

Badge

eARC is an upgrade from ARC it can handle more bandwidth, it is needed to handle Dolby Atmos.

No, standard HDMI ARC can handle the bandwidth necessary for Dolby Digital Plus, which can also carry Atmos. eARC is great, but not a requirement for Atmos. 

Badge

Turning it off doesn’t solve the problem.

It needs to be on, per the link I provided. Perhaps, Drea30,  you might be better off if you were to call Sonos Support directly to discuss it.

When you speak directly to the phone folks, there are more options to assist, and it would be an easier process. 

Sorry, it needs to be ‘on’ for the Sonos to work. I think in order to have your TV speakers to work, turning it ‘off’ is supposed to work, but you may need to reboot your TV, or possibly unplug the Sonos Arc’s HDMI cable.

This is not how HDMI CEC / ARC was designed to be used, so trying to force your way around the way the specification was written is problematic. The engineers (not Sonos) who wrote that spec didn’t expect people to want to switch between external and internal speakers.

But as I said, it’s much more likely the the Sonos reps might have access to information that I don’t...and honestly, this is a Sony issue, not a a Sonos issue, no matter what their CS reps told you. 

Badge

Thanks will try again tomorrow.

Badge

I got in touch with Sonos people, they said it is a TV issue, i tried the sound bar with an older sony tv and there was no problems, so it must be this new model i have now, maybe it will be fixed with a future update.

Badge

@Drea30 Does the older TV have ARC/eARC?  I think that’s still the issue that’s forcing the TV speakers to switch to the Arc.  It just keeps detecting external speakers b/c there’s the connection via eARC as Airgetlam mentioned.  For me, just an overkill to watch cable TV with the Arc on but not the end of the world I guess.  Thanks for sharing your findings.  

Badge

Yes the older tv only had ARC so it must be an issue with eARC, its beyond me.

 

Badge

@Drea30 I contacted Sony support via chat and they confirmed that there’s no way to override the eARC setting to force switch to TV speakers for audio without unplugging it from power. However, I found a workaround inspired by one of Peter Pee’s YouTube vids about Sonos and Smart plugs to reduce standby power consumption!  I connected the Sonos Arc to a wi-fi enabled smart plug.  This way, I can turn the Arc off and on from the app.  When the Arc is off, the TV uses the TV audio (no matter if you have the settings in Audio Output->Speakers→ TV Speakers or External- I tried both, it doesn’t make a difference).  When I want to listen to audio through the Arc, it take 20 seconds (timed) for the plug to power on and the Arc to connect.  The only quirk with this method is that when the Arc turns on and switches from the TV speakers to External, you have to press the up or down button on the volume to reinstate the sound.  To me, that’s not a huge deal and I’m glad I can listen to the TV without the bar on.  

Badge

Thanks for the tip i will try that, although it must be an issue with the tv because i had another soundbar and it worked fine.

Badge

@Drea30 Well, this morning, powered on the TVand no sound from TV speakers unless I power on the Arc. Ugh. Will update if I find another fix. 

Badge

I have sent for a smart plug i will let you know how it goes.

Badge

@Drea30 Cool, lmk if it works for you without issue.  I had to restart the TV (pressed down the power button on the TV remote for 5 seconds) and then it worked again with the TV speakers (obviously not trying to do this each time).  

Badge

@Drea30 Happy to report that since that restart, the sound is working well through TV speakers.  I bought another smart plug for the Sub too so that everything is not always on.  Now I power up both the Arc and Sub with voice control via Alexa.  It’s working great! Hope your experience is similar. 

Badge

Thanks still waiting on the plug hopefully today so will let you know how it goes.

Badge

Got the plug so far works well, what do you think of the Sonos do you have the full set up sub and rear speakers?