Sonos and 5.1 setup with WiFi


Badge

Hello everybody,

 

So in my house I have a couple of Sonos Beam’s (attached to bedroom tv’s) a FIVE and then I have a surround setup as follows in the living room; ARC, Sub Gen 3 and 2x One SL.

 

All of them are connected to my UniFi network (WiFi, no cables) and work fine, however…

A lot of times the surround system breaks up, one of the speakers stops working and suddenly is back or sometimes I even have to resetup some of them (that is, within the surround setup part).


What is the main difference of how the surround 5.1 setup works between those speakers compared to all the other stand alone speaker (those always work fine)? 

So far I can only see that the ARC = WM:1, The SL’s are WM:2 and Sub is WM:2 so i ‘guess’ it uses the ARC as main device and that one connects to the sub and 2x sl, right? Does it do that over the same wifi or creates its own? And if so, is there a way to change that?


3 replies

Userlevel 6
Badge +17

HI @mbnn 

Welcome to the Sonos Community!

The surrounds and Sub will connect directly to the Arc via a dedicated 5GHz link, so they bypass the router altogether. Problems that arise tend to be due to interference, though other things can be a factor. The only way to get your satellites working without using the 5GHz link is to ethernet-wire them (and the Arc) instead, but this shouldn’t be necessary.

I recommend you first try a reboot of your Arc - unplug from power for 20 secs or so.

If that doesn’t help, I recommend you read our help page on Reducing Wireless Interference.

You can also try the following steps on your UniFi system:

  1. Log into the UniFi controller
  2. Click the Settings tab on the left sidebar
  3. Click Wireless Networks under the Settings page
  4. image.png
  5. Change UI back to the old design if needed
  6. Click Edit next to the network SSID
    image.png

     
  7. Verify Guest Policy and disable it if enabled.
    image.png

     
  8. Click on the Save button at the bottom of the page.
  9. Verify and disable the options Block LAN to WLAN Multicast and Broadcast Data and Auto-Optimize Network.
  10. Once completed, allow up to a minute for the AP to provision (apply the settings) and restore online connection.

I hope this helps.

Badge

Hello Thanks, 

Did all that already :) All of the things you said are set as is.

However, you mention a dedicated 5Ghz link, but on what channel is that being broadcasted? Cause the wifi is also broadcasting on 5Ghz (channel 35, 44). Maybe that is what is causing this?

Actually after re-connecting everything once more it seems to be a bit better now.

Userlevel 6
Badge +17

Hi @mbnn 

The Arc will automatically choose the best 5GHz channel to use.

I’m glad to hear things have gotten better, but if issues return it may be best to get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports about the situation.

Reply