Answered

setup Sonos Beam to new Philips OLED

  • 14 January 2022
  • 2 replies
  • 327 views

Hi. I am having difficulties setting up my sonos beam and my new philips oled tv. I have the tv connected to beam using hdmi arc channel and have selected the audio out option as hdmi sound system, however the sound plays through both the tv speakers and the sonos beam creating an echo. I expected that it would play through the sonos only.

Please could you offer some advice on how to resolve this?

icon

Best answer by GuitarSuperstar 14 January 2022, 21:39

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7

There should be an option under the Sound settings on the TV to turn off the TV speakers.

Also be sure to have CEC enabled on your TV. It might be called “EasyLink”. This setting might be found under Installation > Preferences.

Hi,

Thanks for your help. I have tried the turn tv speakers off option, but that results in both hdmi and tv sound turning off. Yet when I select hdmi sound,.it plays through both.

I've just checked the easylink setting and it's set to on. 

I followed some advice on the forum, that stated to power off and unplug all hdmi sources from the tv. Then plug in only the sonos beam and power on. This resolved the issue temporarily. Sound played through sonos beam only, no echo, it sounded great. I then plugged my sky q box and blue ray player and it continued to play sound through the beam only...thought I'd cracked it. Unfortunately the next day it reverted back to playing through both sets of speakers and the echo returned 🤬

I've contacted philips and they have advised a software update so will try that, but any other suggestions would be welcome?

 

Thanks